Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "MQTT version 3.1/3.1.1 client library" |
| 2 | LICENSE = "EPL-1.0 | EDL-1.0" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=eb48c6ee2cb9f5b8b9fe75e6f817bdfc \ |
| 4 | file://epl-v10;md5=8d383c379e91d20ba18a52c3e7d3a979 \ |
| 5 | file://edl-v10;md5=c09f121939f063aeb5235972be8c722c \ |
| 6 | " |
| 7 | SRCNAME = "paho-mqtt" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 8 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 9 | inherit pypi setuptools3 |
| 10 | |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 11 | SRC_URI[md5sum] = "32f93c0ed92c7439f7a715ed258fd35d" |
| 12 | SRC_URI[sha256sum] = "9feb068e822be7b3a116324e01fb6028eb1d66412bf98595ae72698965cb1cae" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | |
| 14 | DEPENDS += "${PYTHON_PN}-pytest-runner-native" |
| 15 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 16 | do_install:append() { |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 17 | install -d -m0755 ${D}${datadir}/${BPN}/examples |
| 18 | cp --preserve=mode,timestamps -R ${S}/examples/* ${D}${datadir}/${BPN}/examples |
| 19 | } |
| 20 | |
| 21 | PACKAGES =+ "${PN}-examples" |
| 22 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 23 | RDEPENDS:${PN}-examples += "${PN}" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 24 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 25 | FILES:${PN}-examples = "${datadir}/${BPN}/examples" |
William A. Kennington III | b95905d | 2021-06-02 12:40:56 -0700 | [diff] [blame] | 26 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 27 | RDEPENDS:${PN} = "\ |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 28 | ${PYTHON_PN}-io \ |
| 29 | ${PYTHON_PN}-logging \ |
| 30 | ${PYTHON_PN}-math \ |
| 31 | ${PYTHON_PN}-netclient \ |
| 32 | ${PYTHON_PN}-threading \ |
| 33 | " |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 34 | |
| 35 | BBCLASSEXTEND = "native nativesdk" |