blob: e64f196004650a53c398661e7c42c557e68922c0 [file] [log] [blame]
Andrew Geisslerc87764f2020-06-27 00:16:32 -05001SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order."
2AUTHOR = "Anthon van der Neut"
3
4LICENSE = "MIT"
Andrew Geissler32b11992021-03-31 13:37:05 -05005LIC_FILES_CHKSUM = "file://LICENSE;md5=fa0a51dfb461e2f803969e0f3fa71dfe"
Andrew Geisslerc87764f2020-06-27 00:16:32 -05006
7PYPI_PACKAGE = "ruamel.yaml"
8
9inherit pypi setuptools3
10
William A. Kennington III49e95662021-09-15 16:19:36 -070011SRC_URI[sha256sum] = "1a771fc92d3823682b7f0893ad56cb5a5c87c48e62b5399d6f42c8759a583b33"
Andrew Geisslerac970dd2021-02-12 15:32:45 -060012
Patrick Williams213cb262021-08-07 19:21:33 -050013RDEPENDS:${PN} += "\
Andrew Geissler69721092021-07-23 12:57:00 -040014 ${PYTHON_PN}-shell \
William A. Kennington III49e95662021-09-15 16:19:36 -070015 ${PYTHON_PN}-datetime \
16 ${PYTHON_PN}-netclient \
Andrew Geissler69721092021-07-23 12:57:00 -040017"
Andrew Geisslerc87764f2020-06-27 00:16:32 -050018
Patrick Williams213cb262021-08-07 19:21:33 -050019do_install:prepend() {
Andrew Geisslerc87764f2020-06-27 00:16:32 -050020 export RUAMEL_NO_PIP_INSTALL_CHECK=1
21}
Andrew Geisslerac970dd2021-02-12 15:32:45 -060022
23BBCLASSEXTEND = "native nativesdk"