blob: 97e57c13d52fc9331e102ccd2ce2680f6f733853 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001DESCRIPTION = "Desktop containment framework."
2HOMEPAGE = "http://flatpak.org"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
5
6SRC_URI = " \
7 gitsm://github.com/flatpak/flatpak;protocol=https;branch=main \
8 file://0001-flatpak-pc-add-pc_sysrootdir.patch \
9 file://0001-meson.build-require-for-native-wayland-scanner.patch \
Patrick Williams56b44a92024-01-19 08:49:29 -060010 file://0001-meson.build-require-native-gtkdoc.patch \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060011"
12
13SRCREV = "27b11b93c2a80a91c9461bc6c7f5e9a201406041"
14
15S = "${WORKDIR}/git"
16
17inherit meson pkgconfig gettext systemd gtk-doc gobject-introspection python3native useradd mime features_check
18
19REQUIRED_DISTRO_FEATURES = "polkit"
20
21DEPENDS = " \
22 appstream \
23 bison-native \
24 dconf \
25 fuse3 \
26 gdk-pixbuf \
27 glib-2.0 \
28 gpgme \
29 json-glib \
30 libarchive \
31 libcap \
32 libxml2 \
33 ostree \
34 polkit \
35 python3-pyparsing-native \
36 zstd \
37"
38
39RDEPENDS:${PN} = " \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060040 ca-certificates \
41 dconf \
42 flatpak-xdg-utils \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060043"
44
Patrick Williamsac13d5f2023-11-24 18:59:46 -060045GIR_MESON_OPTION = "gir"
46GIR_MESON_ENABLE_FLAG = 'enabled'
47GIR_MESON_DISABLE_FLAG = 'disabled'
48GTKDOC_MESON_OPTION = 'gtkdoc'
49GTKDOC_MESON_ENABLE_FLAG = 'enabled'
50GTKDOC_MESON_DISABLE_FLAG = 'disabled'
51
52PACKAGECONFIG[curl] = "-Dhttp_backend=curl,,curl"
53PACKAGECONFIG[docbook_docs] = "-Ddocbook_docs=enabled,-Ddocbook_docs=disabled,xmlto-native"
54PACKAGECONFIG[man] = "-Dman=enabled,-Dman=disabled,libxslt-native"
55PACKAGECONFIG[soup] = "-Dhttp_backend=soup,,libsoup-2.4"
56PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,xauth socat-native"
57PACKAGECONFIG[xauth] = "-Dxauth=enabled,-Dxauth=disabled,xauth"
58PACKAGECONFIG[seccomp] = "-Dseccomp=enabled,-Dseccomp=disabled,libseccomp"
59PACKAGECONFIG[selinux] = "-Dselinux_module=enabled,-Dselinux_module=disabled,libselinux"
60PACKAGECONFIG[wayland-security-context] = "-Dwayland_security_context=enabled,-Dwayland_security_context=disabled,wayland wayland-native wayland-protocols"
61
62PACKAGECONFIG ?= " \
63 curl \
64 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'xauth', '', d)} \
65 ${@bb.utils.contains('DISTRO_FEATURES', 'seccomp', 'seccomp', '', d)} \
66 ${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland-security-context', '', d)} \
67"
68
69FILES:${PN} += "${libdir} ${datadir}"
70
71USERADD_PACKAGES = "${PN}"
72USERADD_PARAM:${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/polkit-1 polkitd"
73
74do_install:append() {
75 chmod 0700 ${D}/${datadir}/polkit-1/rules.d
76 chown polkitd ${D}/${datadir}/polkit-1/rules.d
77 chgrp root ${D}/${datadir}/polkit-1/rules.d
78}