blob: 3db9e2e66f8d8ae9b39f92c466ddaf88a471b972 [file] [log] [blame]
Andrew Geissler9aee5002022-03-30 16:27:02 +00001SUMMARY = "An IPC library for high performance servers"
2DESCRIPTION = "libqb is a library with the primary purpose of providing high performance client server reusable features. \
3It provides high performance logging, tracing, ipc, and poll."
4
5HOMEPAGE = "https://github.com/clusterlabs/libqb/wiki"
6SECTION = "libs"
7LICENSE = "LGPL-2.1-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=321bf41f280cf805086dd5a720b37785"
9
10inherit autotools pkgconfig
11
Patrick Williams2a254922023-08-11 09:48:11 -050012SRCREV = "002171bbcf4bc4728da56c1538afd9e9d814ecaf"
Andrew Geissler9aee5002022-03-30 16:27:02 +000013SRC_URI = "git://github.com/ClusterLabs/${BPN}.git;branch=main;protocol=https \
14 "
15S = "${WORKDIR}/git"
16
17DEPENDS += "libxml2"
18
19CFLAGS += "-pthread -D_REENTRANT"
20
21do_configure:prepend() {
22 ( cd ${S}
23 ${S}/autogen.sh )
24}
25
26BBCLASSEXTEND = "native"