Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 1 | SUMMARY = "Parsing made fun ... using typing." |
| 2 | HOMEPAGE = "https://github.com/hgrecco/flexparser" |
| 3 | LICENSE = "BSD-3-Clause" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=32f547dac365c355d2cdbcd7ebea9144" |
| 5 | |
| 6 | DEPENDS += "python3-setuptools-scm-native" |
| 7 | SRC_URI[sha256sum] = "692e7524d9e14b2b1231b772b091d7d6296951deb383f5a67bfbd0ecb0b9fa9a" |
| 8 | |
| 9 | inherit pypi python_setuptools_build_meta ptest |
| 10 | |
| 11 | PYPI_PACKAGE = "flexparser" |
| 12 | |
| 13 | SRC_URI += " \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | |
| 17 | RDEPENDS:${PN}-ptest += " \ |
| 18 | python3-pytest \ |
| 19 | python3-unittest-automake-output \ |
| 20 | " |
| 21 | |
| 22 | do_install_ptest() { |
| 23 | install -d ${D}${PTEST_PATH}/testsuite |
| 24 | cp -rf ${S}/flexparser/testsuite/* ${D}${PTEST_PATH}/testsuite/ |
| 25 | } |
| 26 | |
| 27 | RDEPENDS:${PN} += " \ |
| 28 | python3-compression \ |
| 29 | python3-email \ |
| 30 | python3-logging \ |
| 31 | " |