blob: 15c0bf06baedca322469b63e0c4be48d06ca8005 [file] [log] [blame]
Patrick Williamsb58112e2024-03-07 11:16:36 -06001SUMMARY = "FreezeGun is a library that allows your Python tests to travel through time by mocking the datetime module."
2HOMEPAGE = "https://github.com/spulec/freezegun"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=acf1d209bb6eddae4cbe6ffd6a0144fe"
5
6SRC_URI[sha256sum] = "10939b0ba0ff5adaecf3b06a5c2f73071d9678e507c5eaedb23c761d56ac774b"
7
8inherit pypi python_setuptools_build_meta ptest
9
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
15 python3-pytest \
16 python3-sqlite3 \
17 python3-unittest-automake-output \
18"
19
20do_install_ptest() {
21 install -d ${D}${PTEST_PATH}/tests
22 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
23}
24
25RDEPENDS:${PN} = "\
26 python3-asyncio \
27 python3-dateutil \
28 python3-unittest \
29"