blob: 70e843a0944af4eabe30a92528426f04822cf99c [file] [log] [blame]
Patrick Williams73bd93f2024-02-20 08:07:48 -06001SUMMARY = "Google Authentication Library"
2DESCRIPTION = "This library provides oauthlib integration with google-auth"
3HOMEPAGE = "https://github.com/googleapis/google-auth-library-python-oauthlib"
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
6
7SRC_URI[sha256sum] = "292d2d3783349f2b0734a0a0207b1e1e322ac193c2c09d8f7c613fb7cc501ea8"
8
Patrick Williams03514f12024-04-05 07:04:11 -05009inherit pypi setuptools3 ptest
Patrick Williams73bd93f2024-02-20 08:07:48 -060010
Patrick Williams03514f12024-04-05 07:04:11 -050011SRC_URI += " \
12 file://run-ptest \
13"
14
15RDEPENDS:${PN}-ptest += " \
16 python3-click \
17 python3-mock \
18 python3-pytest \
19 python3-unittest-automake-output \
20 python3-unixadmin \
21"
22
23do_install_ptest() {
24 install -d ${D}${PTEST_PATH}/tests
25 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
26}
27
28RDEPENDS:${PN} += " \
29 python3-google-auth \
30 python3-requests-oauthlib \
Patrick Williams73bd93f2024-02-20 08:07:48 -060031"