blob: 3aa084d10a93f340188095ccb5ac82d491a0df97 [file] [log] [blame]
Andrew Geisslereff27472021-10-29 15:35:00 -05001SUMMARY = "Self-contained ISO 3166-1 country definitions"
2HOMEPAGE = "https://pypi.org/project/iso3166/"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=5e2f4edc7e7408a82e4a1d05f229b695"
5
Patrick Williamsdb4c27e2022-08-05 08:10:29 -05006SRC_URI[sha256sum] = "fcd551b8dda66b44e9f9e6d6bbbee3a1145a22447c0a556e5d0fb1ad1e491719"
Andrew Geisslereff27472021-10-29 15:35:00 -05007
Andrew Geissler9aee5002022-03-30 16:27:02 +00008inherit pypi python_setuptools_build_meta ptest
Andrew Geisslereff27472021-10-29 15:35:00 -05009
10SRC_URI += " \
11 file://run-ptest \
12"
13
14RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060015 python3-pytest \
16 python3-unittest-automake-output \
Andrew Geisslereff27472021-10-29 15:35:00 -050017"
18
19do_install_ptest() {
20 install -d ${D}${PTEST_PATH}/tests
21 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
22}
23
24RDEPENDS:${PN} += "python3-numbers"
25
26BBCLASSEXTEND = "native nativesdk"