blob: e51264f8a9499bc93cd6a603121970df18e1ea1c [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "Optional static typing for Python 3 and 2 (PEP 484)"
2HOMEPAGE = "https://github.com/python/mypy"
3LICENSE = "MIT & Python-2.0"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=8d62fd8f8648cb018e52857347e340b9"
5
6inherit pypi python_setuptools_build_meta
7
Patrick Williams03514f12024-04-05 07:04:11 -05008SRC_URI[sha256sum] = "3cc5da0127e6a478cddd906068496a97a7618a21ce9b54bde5bf7e539c7af974"
Patrick Williamsac13d5f2023-11-24 18:59:46 -06009
10BBCLASSEXTEND = "native"
11
12DEPENDS += " \
13 python3-mypy-extensions-native \
14 python3-types-psutil-native \
15 python3-types-setuptools-native \
16 python3-typing-extensions-native \
17"
18
19RDEPENDS:${PN} += " \
20 python3-modules \
21 python3-mypy-extensions \
22 python3-typing-extensions \
23"