Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 1 | SUMMARY = "Ninja is a small build system with a focus on speed" |
| 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://LICENSE_Apache_20;md5=19cbd64715b51267a47bf3750cc6a8a5" |
| 4 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 5 | PYPI_PACKAGE = "ninja" |
| 6 | PYPI_ARCHIVE_NAME_PREFIX = "pypi-" |
| 7 | |
| 8 | inherit pypi python_setuptools_build_meta |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 9 | SRC_URI[sha256sum] = "9d793b08dd857e38d0b6ffe9e6b7145d7c485a42dcfea04905ca0cdb6017cc3c" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 10 | |
Andrew Geissler | 3eeda90 | 2023-05-19 10:14:02 -0500 | [diff] [blame] | 11 | SRC_URI += "file://no-scikit-build.patch \ |
| 12 | file://run-ninja-from-path.patch" |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 13 | |
Patrick Williams | 3965356 | 2024-03-01 08:54:02 -0600 | [diff] [blame] | 14 | DEPENDS += "python3-setuptools-scm-native" |
Patrick Williams | 169d7bc | 2024-01-05 11:33:25 -0600 | [diff] [blame] | 15 | |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 16 | do_install:append () { |
| 17 | rm -rf ${D}${bindir} |
| 18 | } |
| 19 | |
Patrick Williams | b542dec | 2023-06-09 01:26:37 -0500 | [diff] [blame] | 20 | RDEPENDS:${PN} = " \ |
| 21 | ninja \ |
| 22 | python3-io \ |
| 23 | python3-json \ |
| 24 | python3-ninja-syntax \ |
| 25 | " |
Andrew Geissler | fc113ea | 2023-03-31 09:59:46 -0500 | [diff] [blame] | 26 | |
| 27 | BBCLASSEXTEND = "native nativesdk" |