blob: 12f4f908af7aae1848b4a180d4641de16d737d48 [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY="Pylint is a Python source code analyzer"
2HOMEPAGE= "http://www.pylint.org/"
3LICENSE = "GPL-2.0-only"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=c107cf754550e65755c42985a5d4e9c9"
5
Patrick Williams03514f12024-04-05 07:04:11 -05006SRC_URI += "git://github.com/pylint-dev/pylint;branch=maintenance/3.1.x;protocol=https \
7 file://0001-Adjust-test-expectations-for-ptest.patch \
Patrick Williamsac13d5f2023-11-24 18:59:46 -06008 file://run-ptest \
9 "
Patrick Williams03514f12024-04-05 07:04:11 -050010SRCREV = "053c2c3a25f97f043e10cdd41d2609e495a68f57"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060011
12inherit python_setuptools_build_meta ptest
13
Patrick Williams73bd93f2024-02-20 08:07:48 -060014RDEPENDS:${PN} += "\
15 python3-astroid \
16 python3-difflib \
17 python3-dill \
18 python3-isort \
19 python3-json \
20 python3-mccabe \
21 python3-netserver \
22 python3-numbers \
23 python3-pkgutil \
24 python3-platformdirs \
25 python3-shell \
26 python3-tomlkit \
27 "
Patrick Williamsac13d5f2023-11-24 18:59:46 -060028
29RDEPENDS:${PN}-ptest += " \
Patrick Williams73bd93f2024-02-20 08:07:48 -060030 python3-core \
31 python3-git \
32 python3-py \
33 python3-pytest \
34 python3-pytest-benchmark \
35 python3-pytest-runner \
36 python3-pytest-timeout \
37 python3-pytest-xdist \
38 python3-requests \
39 python3-statistics \
40 python3-tomllib \
41 python3-typing-extensions \
42 python3-unittest-automake-output \
43 "
Patrick Williamsac13d5f2023-11-24 18:59:46 -060044
45S = "${WORKDIR}/git"
46
47do_install_ptest() {
48 install -d ${D}${PTEST_PATH}/tests
49 cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
50 install -Dm 0644 ${S}/tests/.pylint_primer_tests/.gitkeep ${D}${PTEST_PATH}/tests/.pylint_primer_tests/.gitkeep
51 sed -i 's#/usr/bin/python$#/usr/bin/python3#g' ${D}${PTEST_PATH}/tests/data/ascript
Patrick Williams73bd93f2024-02-20 08:07:48 -060052 # regression_distutil_import_error_73.py fails to run see
Patrick Williams705982a2024-01-12 09:51:57 -060053 # https://lists.openembedded.org/g/openembedded-devel/topic/103181847
54 rm ${D}${PTEST_PATH}/tests/functional/r/regression_02/regression_distutil_import_error_73.py
Patrick Williamsac13d5f2023-11-24 18:59:46 -060055}
56
57BBCLASSEXTEND = "native nativesdk"