Patrick Williams | 03514f1 | 2024-04-05 07:04:11 -0500 | [diff] [blame] | 1 | SUMMARY = "WebSockets state-machine based protocol implementation" |
| 2 | HOMEPAGE = "https://github.com/python-hyper/wsproto/" |
| 3 | LICENSE = "MIT" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=69fabf732409f4ac61875827b258caaf" |
| 5 | |
| 6 | inherit pypi setuptools3 ptest |
| 7 | |
| 8 | SRC_URI[sha256sum] = "ad565f26ecb92588a3e43bc3d96164de84cd9902482b130d0ddbaa9664a85065" |
| 9 | |
| 10 | SRC_URI += " \ |
| 11 | file://run-ptest \ |
| 12 | " |
| 13 | |
| 14 | RDEPENDS:${PN}-ptest += " \ |
| 15 | python3-pytest \ |
| 16 | python3-unittest-automake-output \ |
| 17 | " |
| 18 | |
| 19 | do_install_ptest() { |
| 20 | install -d ${D}${PTEST_PATH}/tests |
| 21 | cp -rf ${S}/test/* ${D}${PTEST_PATH}/tests/ |
| 22 | } |
| 23 | |
| 24 | RDEPENDS:${PN} += " \ |
| 25 | python3-h11 \ |
| 26 | python3-netclient \ |
| 27 | " |