Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "GEGL (Generic Graphics Library) is a graph based image processing framework" |
| 2 | LICENSE = "GPLv3" |
| 3 | LIC_FILES_CHKSUM = "file://COPYING;md5=f1a8bfcbc85304df454b65d378b299c7" |
| 4 | |
| 5 | DEPENDS = " \ |
| 6 | intltool-native \ |
| 7 | babl \ |
| 8 | glib-2.0 \ |
| 9 | pango \ |
| 10 | cairo \ |
| 11 | expat \ |
| 12 | zlib \ |
| 13 | \ |
| 14 | json-glib \ |
| 15 | " |
| 16 | |
| 17 | GNOMEBASEBUILDCLASS = "meson" |
| 18 | |
| 19 | inherit features_check gnomebase vala gobject-introspection |
| 20 | |
| 21 | REQUIRED_DISTRO_FEATURES = "x11" |
| 22 | |
| 23 | SHPV = "${@gnome_verdir("${PV}")}" |
| 24 | |
| 25 | SRC_URI = " \ |
| 26 | https://download.gimp.org/pub/${BPN}/${SHPV}/${BP}.tar.xz \ |
| 27 | file://0001-meson.build-Give-note-if-sdl2-was-found.patch \ |
| 28 | " |
Andrew Geissler | 89770b0 | 2020-06-13 10:40:47 -0500 | [diff] [blame] | 29 | SRC_URI[md5sum] = "3a8062add20effb6f92b4b614facbbd5" |
| 30 | SRC_URI[sha256sum] = "7765499f27341b0d16032e665319cbc12876483ff6a944fcdf24a9c58e3e254a" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 31 | |
| 32 | PACKAGECONFIG ??= "gexiv2 jpeg libpng librsvg sdl2" |
| 33 | PACKAGECONFIG_class-native = "libpng librsvg" |
| 34 | |
| 35 | PACKAGECONFIG[jasper] = "-Djasper=enabled,-Djasper=disabled,jasper" |
| 36 | PACKAGECONFIG[gexiv2] = "-Dgexiv2=enabled,-Dgexiv2=disabled,gexiv2" |
| 37 | PACKAGECONFIG[graphviz] = "-Dgraphviz=enabled,-Dgraphviz=disabled,graphviz" |
| 38 | PACKAGECONFIG[jpeg] = "-Dlibjpeg=enabled,-Dlibjpeg=disabled,jpeg" |
| 39 | PACKAGECONFIG[lcms] = "-Dlcms=enabled,-Dlcms=disabled,lcms" |
| 40 | PACKAGECONFIG[libav] = "-Dlibav=enabled,-Dlibav=disabled,libav" |
| 41 | PACKAGECONFIG[libpng] = "-Dlibpng=enabled,-Dlibpng=disabled,libpng" |
| 42 | PACKAGECONFIG[librsvg] = "-Dlibrsvg=enabled,-Dlibrsvg=disabled,librsvg" |
| 43 | PACKAGECONFIG[sdl] = "-Dsdl1=enabled,-Dsdl1=disabled,virtual/libsdl" |
| 44 | PACKAGECONFIG[sdl2] = "-Dsdl2=enabled,-Dsdl2=disabled,virtual/libsdl2" |
| 45 | PACKAGECONFIG[tiff] = "-Dlibtiff=enabled,-Dlibtiff=disabled,tiff" |
| 46 | PACKAGECONFIG[webp] = "-Dwebp=enabled,-Dwebp=disabled,webp" |
| 47 | |
| 48 | # There are a couple of non-symlink .so files installed into libdir, which need to go into main package |
| 49 | FILES_${PN} += " \ |
| 50 | ${libdir}/*.so \ |
| 51 | ${libdir}/gegl-${SHPV}/*.json \ |
| 52 | ${libdir}/gegl-${SHPV}/*.so \ |
| 53 | " |
| 54 | FILES_SOLIBSDEV = "${libdir}/libgegl-${SHPV}${SOLIBSDEV}" |
| 55 | |
| 56 | # Fails to build with thumb-1 (qemuarm) |
| 57 | # gegl-0.2.0/operations/common/matting-global.c: In function 'matting_process': |
| 58 | # gegl-0.2.0/operations/common/matting-global.c:463:1: internal compiler error: in patch_jump_insn, at cfgrtl.c:1275 |
| 59 | ARM_INSTRUCTION_SET = "arm" |
| 60 | |
| 61 | BBCLASSEXTEND = "native" |