Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 1 | SUMMARY = "kexecboot linux-as-bootloader" |
| 2 | DESCRIPTION = "kexecboot is a graphical linux-as-bootloader implementation based on kexec." |
| 3 | HOMEPAGE = "http://kexecboot.org" |
| 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f" |
| 6 | PV = "0.6+git${SRCPV}" |
| 7 | S = "${WORKDIR}/git" |
| 8 | SRC_URI = "git://github.com/kexecboot/kexecboot.git" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 9 | SRC_URI:append:libc-klibc = "\ |
Andrew Geissler | ac970dd | 2021-02-12 15:32:45 -0600 | [diff] [blame] | 10 | file://0001-kexecboot-Use-new-reboot-API-with-klibc.patch \ |
| 11 | file://0001-make-Add-compiler-includes-in-cflags.patch \ |
| 12 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 13 | SRCREV = "5a5e04be206140059f42ac786d424da1afaa04b6" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 14 | inherit autotools |
| 15 | |
| 16 | EXTRA_OECONF = "--enable-textui --enable-delay=2 --enable-evdev-rate=1000,250" |
| 17 | |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 18 | CFLAGS += "-fcommon" |
| 19 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 20 | do_install () { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 21 | install -D -m 0755 ${B}/src/kexecboot ${D}${bindir}/kexecboot |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 22 | install -d ${D}/proc |
| 23 | install -d ${D}/mnt |
| 24 | install -d ${D}/dev |
| 25 | install -d ${D}/sys |
| 26 | } |
| 27 | |
| 28 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | FILES:${PN} += " ${bindir}/kexecboot /init /proc /mnt /dev /sys" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 31 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 32 | pkg_postinst:${PN} () { |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 33 | ln -sf ${bindir}/kexecboot $D/init |
| 34 | } |
| 35 | |
| 36 | BBCLASSEXTEND = "klibc" |