Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "A command line tool for updating and displaying info about boot loaders" |
| 2 | DESCRIPTION = "grubby is a command line tool for updating and displaying information \ |
| 3 | about the configuration files for the grub, lilo, elilo (ia64), yaboot (powerpc) and \ |
| 4 | zipl (s390) boot loaders. It is primarily designed to be used from scripts which install \ |
| 5 | new kernels and need to find information about the current boot environment. \ |
| 6 | " |
| 7 | HOMEPAGE = "https://github.com/rhboot/grubby" |
| 8 | LICENSE = "GPLv2+" |
| 9 | |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=892f569a555ba9c07a568a7c0c4fa63a" |
| 11 | |
| 12 | DEPENDS = "popt util-linux" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 13 | DEPENDS:append:libc-musl = " libexecinfo" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | SRCREV = "a1d2ae93408c3408e672d7eba4550fdf27fb0201" |
| 17 | SRC_URI = "git://github.com/rhboot/grubby.git;protocol=https; \ |
| 18 | file://grubby-rename-grub2-editenv-to-grub-editenv.patch \ |
| 19 | file://run-ptest \ |
| 20 | file://0001-Add-another-variable-LIBS-to-provides-libraries-from.patch \ |
| 21 | file://0002-include-paths.h-for-_PATH_MOUNTED.patch \ |
| 22 | " |
| 23 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 24 | RDEPENDS:${PN} += "dracut" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 25 | |
| 26 | inherit autotools-brokensep ptest |
| 27 | |
Brad Bishop | 0f291cc | 2019-09-01 15:16:57 -0400 | [diff] [blame] | 28 | EXTRA_OEMAKE = "-e 'CC=${CC}' 'LDFLAGS=${LDFLAGS}' LIBS='${LIBS}' 'PREFIX'=${@bb.utils.contains('DISTRO_FEATURES','usrmerge','/usr','',d)}" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 30 | LIBS:libc-musl = "-lexecinfo" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | LIBS ?= "" |
| 32 | do_install_ptest() { |
| 33 | install -d ${D}${PTEST_PATH} |
| 34 | cp -r ${S}/test ${S}/test.sh ${D}${PTEST_PATH} |
| 35 | sed -i 's|./grubby|grubby|' ${D}${PTEST_PATH}/test.sh |
| 36 | } |
| 37 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 38 | RDEPENDS:${PN} += "bash" |
| 39 | RDEPENDS:${PN}-ptest = "util-linux-getopt bash" |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 40 | |
| 41 | COMPATIBLE_HOST = '(x86_64.*|i.86.*)-(linux|freebsd.*)' |