Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "libgphoto2 allows you to access digital cameras" |
| 2 | SECTION = "libs" |
| 3 | LICENSE = "LGPLv2.1" |
| 4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0448d3676bc0de00406af227d341a4d1" |
| 5 | |
| 6 | DEPENDS = "libtool jpeg virtual/libusb0 libexif zlib libxml2" |
| 7 | |
| 8 | # The .fdi and .rules files were generated with: |
| 9 | # libgphoto2-2.5.8/packaging/generic$ qemu-arm -s 1048576 -r 2.6.24 -L /OE/angstrom-dev/staging/armv5te-angstrom-linux-gnueabi/ .libs/print-camera-list |
| 10 | # They are release specific, so please regen when adding new releases |
| 11 | |
| 12 | SRC_URI = "${SOURCEFORGE_MIRROR}/gphoto/libgphoto2-${PV}.tar.bz2;name=libgphoto2 \ |
| 13 | file://40-libgphoto2.rules \ |
| 14 | file://0001-configure.ac-remove-AM_PO_SUBDIRS.patch \ |
| 15 | " |
| 16 | |
Andrew Geissler | 97771a3 | 2021-03-05 15:23:11 -0600 | [diff] [blame] | 17 | SRC_URI[libgphoto2.md5sum] = "83a2f96dade72e95dffb8e5fa9628d7e" |
| 18 | SRC_URI[libgphoto2.sha256sum] = "f8b85478c44948a0b0b52c4d4dfda2de1d7bcb7b262c76bd1ae306d9c63240d7" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | |
| 20 | inherit autotools pkgconfig gettext lib_package |
| 21 | |
| 22 | EXTRA_OECONF = " --with-drivers=all udevscriptdir=${nonarch_base_libdir}/udev ac_cv_lib_ltdl_lt_dlcaller_register=yes" |
| 23 | |
| 24 | PACKAGECONFIG ??= "" |
| 25 | PACKAGECONFIG[gd] = ",--without-gdlib,gd" |
| 26 | PACKAGECONFIG[serial] = "--enable-serial,--disable-serial,lockdev" |
| 27 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 28 | do_configure:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | cp ${STAGING_DATADIR_NATIVE}/gettext/po/Makefile.in.in ${S}/libgphoto2_port/po/ |
| 30 | cd ${S}/libgphoto2_port/ |
| 31 | autoreconf -Wcross --verbose --install --force ${EXTRA_AUTORECONF} $acpaths |
Andrew Geissler | a2681d9 | 2020-10-16 10:17:07 -0500 | [diff] [blame] | 32 | |
| 33 | # remove WORKDIR information from config to improve reproducibility |
| 34 | # libgphoto2_port recheck config will set the WORKDIR info again, so dont do that |
| 35 | sed -i 's/'$(echo ${WORKDIR} | sed 's_/_\\/_g')'/../g' ${B}/config.h |
| 36 | sed -i 's/'$(echo ${WORKDIR} | sed 's_/_\\/_g')'/../g' ${B}/libgphoto2_port/config.status |
| 37 | sed -i '/config\.status/ s/\-\-recheck//' ${B}/libgphoto2_port/Makefile |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 38 | cd ${S} |
| 39 | } |
| 40 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 41 | do_install:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 42 | install -d ${D}${sysconfdir}/udev/rules.d/ |
| 43 | install -m 0644 ${WORKDIR}/*.rules ${D}${sysconfdir}/udev/rules.d/ |
| 44 | } |
| 45 | |
| 46 | PACKAGES =+ "libgphotoport libgphoto2-camlibs" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 47 | FILES:libgphoto2-camlibs = "${libdir}/libgphoto2*/*/*.so*" |
| 48 | RRECOMMENDS:${PN} = "libgphoto2-camlibs" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 49 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 50 | FILES:libgphotoport = "${libdir}/libgphoto2_port.so.*" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 51 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 52 | FILES:${PN} += "${nonarch_base_libdir}/udev/*" |
| 53 | FILES:${PN}-dbg += "${libdir}/*/*/.debug" |
| 54 | FILES:${PN}-dev += "${libdir}/*/*/*.la" |
| 55 | FILES:${PN}-doc += "${datadir}/libgphoto2_port/0.12.0/vcamera/README.txt" |