Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Script to properly configure BT-HCI on Raspberry Pi" |
| 2 | HOMEPAGE = "https://github.com/RPi-Distro/pi-bluetooth" |
| 3 | SECTION = "kernel" |
| 4 | LICENSE = "BSD-3-Clause" |
| 5 | LIC_FILES_CHKSUM = "\ |
| 6 | file://debian/copyright;md5=6af8de3c8ee71f8e91e9b22f84ff2022 \ |
| 7 | " |
| 8 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 9 | SRC_URI = "\ |
| 10 | git://github.com/RPi-Distro/pi-bluetooth \ |
| 11 | file://0001-bthelper-correct-path-for-hciconfig-under-Yocto.patch \ |
| 12 | " |
Andrew Geissler | a4353c8 | 2021-06-25 14:23:27 -0500 | [diff] [blame] | 13 | SRCREV = "fd4775bf90e037551532fc214a958074830bb80d" |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 17 | # hciuart.service replaces what was brcm43438.service |
| 18 | inherit systemd |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 19 | SYSTEMD_SERVICE:${PN} = "\ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 20 | hciuart.service \ |
| 21 | bthelper@.service \ |
| 22 | " |
| 23 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 24 | do_install() { |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 25 | install -d ${D}${sysconfdir}/udev/rules.d |
| 26 | install -m 0644 ${S}/lib/udev/rules.d/* ${D}${sysconfdir}/udev/rules.d |
| 27 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 28 | install -d ${D}${bindir} |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 29 | install -m 0755 ${S}/usr/bin/bthelper ${D}${bindir} |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 30 | install -m 0755 ${S}/usr/bin/btuart ${D}${bindir} |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 31 | |
| 32 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 33 | install -d ${D}${systemd_system_unitdir} |
| 34 | install -m 0644 ${S}/debian/pi-bluetooth.bthelper@.service ${D}${systemd_system_unitdir}/bthelper@.service |
| 35 | install -m 0644 ${S}/debian/pi-bluetooth.hciuart.service ${D}${systemd_system_unitdir}/hciuart.service |
| 36 | fi |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 37 | } |
| 38 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | FILES:${PN} = "\ |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 40 | ${bindir} \ |
| 41 | ${sysconfdir} \ |
| 42 | ${systemd_unitdir}/system \ |
| 43 | " |
Brad Bishop | 870eb53 | 2020-01-06 09:44:45 -0500 | [diff] [blame] | 44 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | RDEPENDS:${PN} += " \ |
Brad Bishop | 870eb53 | 2020-01-06 09:44:45 -0500 | [diff] [blame] | 46 | udev-rules-rpi \ |
| 47 | " |