Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 1 | SUMMARY = "Regular expressions library" |
| 2 | DESCRIPTION = "Oniguruma is a modern and flexible regular expressions library. \ |
| 3 | It encompasses features from different regular expression \ |
| 4 | implementations that traditionally exist in different languages. \ |
| 5 | Character encoding can be specified per regular expression object." |
| 6 | HOMEPAGE = "https://github.com/kkos/oniguruma" |
| 7 | LICENSE = "BSD-2-Clause" |
| 8 | LIC_FILES_CHKSUM = "file://COPYING;md5=1ee043784bdce7503e619b2d1a85798b" |
| 9 | |
| 10 | SRC_URI = "\ |
| 11 | https://github.com/kkos/oniguruma/releases/download/v${PV}/${BP}.tar.gz \ |
| 12 | file://0001-build-don-t-link-against-host-system-libraries.patch \ |
| 13 | file://0001-build-enable-serial-tests-automake-option-for-ptest.patch \ |
| 14 | file://run-ptest \ |
| 15 | " |
| 16 | |
| 17 | SRC_URI[md5sum] = "a12d2fe997b789bd87cf63799c091879" |
| 18 | SRC_URI[sha256sum] = "4669d22ff7e0992a7e93e116161cac9c0949cd8960d1c562982026726f0e6d53" |
| 19 | |
| 20 | BINCONFIG = "${bindir}/onig-config" |
| 21 | |
| 22 | inherit autotools binconfig-disabled ptest |
| 23 | |
| 24 | BBCLASSEXTEND = "native" |
| 25 | |
| 26 | do_compile_ptest() { |
| 27 | oe_runmake -C test buildtest-TESTS |
| 28 | } |
| 29 | |
| 30 | do_install_ptest() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 31 | mkdir -p ${D}${PTEST_PATH}/tests |
| 32 | install -m 0755 -t ${D}${PTEST_PATH}/tests/ ${B}/test/.libs/* |
Brad Bishop | e42b3e3 | 2020-01-15 22:08:42 -0500 | [diff] [blame] | 33 | } |
Andrew Geissler | f103a7f | 2021-05-07 16:09:40 -0500 | [diff] [blame] | 34 | |
| 35 | PROVIDES += "oniguruma" |