Andrew Geissler | 595f630 | 2022-01-24 19:11:47 +0000 | [diff] [blame] | 1 | SUMMARY = "Bash Automated Testing System" |
| 2 | DESCRIPTION = "Bats is a TAP-compliant testing framework for Bash. It \ |
| 3 | provides a simple way to verify that the UNIX programs you write behave as expected." |
| 4 | AUTHOR = "Sam Stephenson & bats-core organization" |
| 5 | HOMEPAGE = "https://github.com/bats-core/bats-core" |
| 6 | LICENSE = "MIT" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=2970203aedf9e829edb96a137a4fe81b" |
| 8 | |
| 9 | SRC_URI = "git://github.com/bats-core/bats-core.git;branch=master;protocol=https" |
| 10 | # v1.4.1 |
| 11 | SRCREV = "99d64eb017abcd6a766dd0d354e625526da69cb3" |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | do_configure:prepend() { |
| 16 | sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats |
| 17 | sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats-exec-file |
| 18 | sed -i 's:\$BATS_ROOT/lib:\$BATS_ROOT/${baselib}:g' ${S}/libexec/bats-core/bats-exec-test |
| 19 | } |
| 20 | |
| 21 | do_install() { |
| 22 | # Just a bunch of bash scripts to install |
| 23 | ${S}/install.sh ${D}${prefix} ${baselib} |
| 24 | } |
| 25 | |
| 26 | RDEPENDS:${PN} = "bash" |
| 27 | FILES:${PN} += "${libdir}/bats-core/*" |
| 28 | |
| 29 | PACKAGECONFIG ??= "pretty" |
| 30 | PACKAGECONFIG[pretty] = ",,,ncurses" |