Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "High Availability monitor built upon LVS, VRRP and service pollers" |
| 2 | DESCRIPTION = "Keepalived is a routing software written in C. The main goal \ |
| 3 | of this project is to provide simple and robust facilities for loadbalancing \ |
| 4 | and high-availability to Linux system and Linux based infrastructures. \ |
| 5 | Loadbalancing framework relies on well-known and widely used Linux Virtual \ |
| 6 | Server (IPVS) kernel module providing Layer4 loadbalancing \ |
| 7 | " |
| 8 | HOMEPAGE = "http://www.keepalived.org/" |
| 9 | |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 10 | LICENSE = "GPL-2.0-only" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 12 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 13 | SRC_URI = "http://www.keepalived.org/software/${BP}.tar.gz \ |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 14 | " |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 15 | SRC_URI[sha256sum] = "85882eb62974f395d4c631be990a41a839594a7e62fbfebcb5649a937a7a1bb6" |
Andrew Geissler | bffdb3e | 2020-08-21 16:13:29 -0500 | [diff] [blame] | 16 | UPSTREAM_CHECK_URI = "https://github.com/acassen/keepalived/releases" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 17 | |
| 18 | DEPENDS = "libnfnetlink openssl" |
| 19 | |
| 20 | inherit autotools pkgconfig systemd |
| 21 | |
| 22 | PACKAGECONFIG ??= "libnl snmp \ |
| 23 | ${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)} \ |
| 24 | " |
| 25 | PACKAGECONFIG[libnl] = "--enable-libnl,--disable-libnl,libnl" |
| 26 | PACKAGECONFIG[snmp] = "--enable-snmp,--disable-snmp,net-snmp" |
| 27 | PACKAGECONFIG[systemd] = "--with-init=systemd --with-systemdsystemunitdir=${systemd_system_unitdir},--with-init=SYSV,systemd" |
| 28 | |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 29 | EXTRA_OEMAKE = "initdir=${sysconfdir}/init.d" |
| 30 | |
Andrew Geissler | 220dafd | 2023-10-04 10:18:08 -0500 | [diff] [blame] | 31 | export EXTRA_CFLAGS = "${CFLAGS}" |
| 32 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 33 | do_install:append() { |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 34 | if [ -f ${D}${sysconfdir}/init.d/${BPN} ]; then |
| 35 | chmod 0755 ${D}${sysconfdir}/init.d/${BPN} |
| 36 | sed -i 's#rc.d/##' ${D}${sysconfdir}/init.d/${BPN} |
| 37 | fi |
| 38 | |
| 39 | if ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'true', 'false', d)}; then |
| 40 | install -D -m 0644 ${B}/${BPN}/${BPN}.service ${D}${systemd_system_unitdir}/${BPN}.service |
| 41 | fi |
| 42 | } |
| 43 | |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 44 | PACKAGE_BEFORE_PN = "${PN}-samples" |
| 45 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 46 | FILES:${PN} += "${datadir}/snmp/mibs/KEEPALIVED-MIB.txt" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 47 | |
Patrick Williams | 705982a | 2024-01-12 09:51:57 -0600 | [diff] [blame] | 48 | FILES:${PN}-samples = "${sysconfdir}/keepalived/samples ${sysconfdir}/keepalived/keepalived.conf.sample" |
| 49 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 50 | SYSTEMD_SERVICE:${PN} = "keepalived.service" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 51 | SYSTEMD_AUTO_ENABLE ?= "disable" |