blob: 32c4783cf7643be2f18f8d60a7fd6f41d90414d7 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001SUMMARY = "Hardware Platform Interface Library and Tools"
2
3DESCRIPTION = "\
4OpenHPI is an open source project created with the intent of providing an \
5implementation of the SA Forum's Hardware Platform Interface (HPI). HPI \
6provides an abstracted interface to managing computer hardware, typically for \
7chassis and rack based servers. HPI includes resource modeling; access to and \
8control over sensor, control, watchdog, and inventory data associated with \
9resources; abstracted System Event Log interfaces; hardware events and alerts; \
10and a managed hotswap interface. \
11\
12OpenHPI provides a modular mechanism for adding new hardware and device support \
13easily. Many plugins exist in the OpenHPI source tree to provide access to \
14various types of hardware. This includes, but is not limited to, IPMI based \
15servers, Blade Center, and machines which export data via sysfs. \
16"
17
18HOMEPAGE = "http://openhpi.sourceforge.net/Home"
19SECTION = "net"
Brad Bishop2d39a062019-10-28 08:33:36 -040020LICENSE = "BSD-3-Clause"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080021LIC_FILES_CHKSUM = "file://COPYING;md5=e3c772a32386888ccb5ae1c0ba95f1a4"
22
23DEPENDS = "net-snmp libxml2 ncurses openssl glib-2.0 popt e2fsprogs \
24 autoconf-archive-native os-release"
25
26SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \
27 file://openhpi.init \
28 file://openhpid.service \
29 file://run-ptest \
30 file://openhpi-netsnmp-cross-compile.patch \
31 file://openhpi-sysfs-cross-compile.patch \
32 file://openhpi-libxml2-cross-compile.patch \
33 file://openhpi-glib-cross-compile.patch \
34 file://openhpi-linkfix.patch \
35 file://openhpi-fix-host-gcc.patch \
Brad Bishopc342db32019-05-15 21:57:59 -040036 file://openhpi-fix-function-saHpiSensorThresholds.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080037 file://openhpi-add-libnetsnmp-when-link.patch \
38 file://openhpi-invalide-session.patch \
39 file://openhpi-use-serial-tests-config-needed-by-ptest.patch \
40 file://openhpi-fix-alignment-issue.patch \
41 file://c++11.patch \
42 file://clang-c++11.patch \
43 file://fix-narrowing-warning.patch \
44 file://0001-session-close-socket.patch \
45 file://openhpi-3.6.1-ssl.patch \
46 file://0001-Do-not-poke-at-build-host-s-etc-os-release.patch \
47 file://cross_899198.patch \
48 file://no-md2.patch \
49 file://0001-include-iostream-for-cout.patch \
50 "
51SRC_URI[md5sum] = "fffda3deea8a0d3671a72eea9d13a4df"
52SRC_URI[sha256sum] = "c94332a29160dd75cb799c027e614690c00263b0fabed87417707bec04c38723"
53
54inherit autotools pkgconfig ptest update-rc.d systemd
55
56PACKAGES =+ "${PN}-libs"
57
Patrick Williams213cb262021-08-07 19:21:33 -050058FILES:${PN}-libs = "${libdir}/${BPN}/*.so /usr/lib/${BPN}/*.so"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080059
Patrick Williams213cb262021-08-07 19:21:33 -050060INSANE_SKIP:${PN}-libs = "dev-so"
61RDEPENDS:${PN} += "${PN}-libs"
Patrick Williams39653562024-03-01 08:54:02 -060062RDEPENDS:${PN}-ptest += "packagegroup-core-buildessential"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080063
Brad Bishop19323692019-04-05 15:28:33 -040064PACKAGECONFIG ??= "libgcrypt non32bit snmp-bc"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080065PACKAGECONFIG[sysfs] = "--enable-sysfs,--disable-sysfs,sysfsutils,"
66PACKAGECONFIG[libgcrypt] = "--enable-encryption,--disable-encryption,libgcrypt,"
67PACKAGECONFIG[non32bit] = "--enable-non32bit-int,--disable-non32bit-int,,"
Brad Bishop19323692019-04-05 15:28:33 -040068PACKAGECONFIG[snmp-bc] = "--enable-snmp_bc,--disable-snmp_bc"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080069
70export DISTRO
71
Patrick Williams213cb262021-08-07 19:21:33 -050072do_install:append () {
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080073 install -m 0755 -d ${D}${sysconfdir}/${BPN}
Brad Bishopc342db32019-05-15 21:57:59 -040074 install -m 0644 ${S}/openhpiclient.conf.example ${D}${sysconfdir}/${BPN}/openhpiclient.conf
75 install -m 0600 ${S}/openhpi.conf.example ${D}${sysconfdir}/${BPN}/openhpi.conf
76 install -m 0644 ${S}/simulation.data.example ${D}${sysconfdir}/${BPN}/simulation.data
77 install -m 0644 ${S}/test_agent.data.example ${D}${sysconfdir}/${BPN}/test_agent.data
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080078 install -m 0755 ${WORKDIR}/openhpi.init ${D}${sysconfdir}/init.d/openhpid
79
80 install -d ${D}${systemd_unitdir}/system
81 install -m 0644 ${WORKDIR}/openhpid.service ${D}${systemd_unitdir}/system
82 sed -i -e "s,@SBINDIR@,${sbindir},g" -e "s,@SYSCONFDIR@,${sysconfdir},g" \
83 ${D}${systemd_unitdir}/system/openhpid.service
84}
85
86do_compile_ptest () {
87 for x in `find ${B} -name Makefile -exec grep -l buildtest-TESTS {} \;`; do
88 dir=`dirname ${x}`
Brad Bishopa891d152019-09-13 06:17:45 -040089 case $dir in
90 *cpp/t) ;;
91 *snmp_bc/t) if ${@bb.utils.contains('PACKAGECONFIG','snmp-bc','true','false',d)}
92 then
93 oe_runmake -C ${dir} buildtest-TESTS
94 fi
95 ;;
96 *) oe_runmake -C ${dir} buildtest-TESTS ;;
97 esac
98 done
99}
100
101ack_do_compile_ptest () {
102 for x in `find ${B} -name Makefile -exec grep -l buildtest-TESTS {} \;`; do
103 dir=`dirname ${x}`
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800104 upper=`dirname ${dir}`
105 if [ `basename ${upper}` != "cpp" ]; then
106 oe_runmake -C ${dir} buildtest-TESTS
107 fi
108 done
109}
110
111do_install_ptest () {
112 cp -rf ${B}/openhpid/t/ohpi/.libs/* ${B}/openhpid/t/ohpi/
113 TESTS="utils marshal openhpid"
114 for subtest in ${TESTS}; do
115 mkdir -p ${D}${PTEST_PATH}/${subtest}/t
116 cp -rf ${B}/${subtest}/t/* ${D}${PTEST_PATH}/${subtest}/t
117 done
118
119 for x in `find ${D}${PTEST_PATH} -name Makefile`; do
120 sed -i "s:${S}:${PTEST_PATH}/:g" ${x};
121 sed -i "s/^Makefile:/MM:/g" ${x};
122 done;
123
Brad Bishopc342db32019-05-15 21:57:59 -0400124 install -m 644 ${S}/openhpid/t/ohpi/openhpi.conf ${D}${PTEST_PATH}/openhpid/t/ohpi/
125 sed -i "s:OPENHPI_CONF=[^ ]*:OPENHPI_CONF=./openhpi.conf:g" ${D}${PTEST_PATH}/openhpid/t/ohpi/Makefile
126
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800127 mkdir -p ${D}${PTEST_PATH}/plugins/watchdog/
128 cp -L ${D}/${libdir}/${BPN}/libwatchdog.so ${D}${PTEST_PATH}/plugins/watchdog/
129 cp -L ${D}/${libdir}/${BPN}/libsimulator.so ${D}${PTEST_PATH}/plugins/watchdog/
130 find ${D}${PTEST_PATH}/ -name "*.c" -exec rm {} \;
131 find ${D}${PTEST_PATH}/ -name "*.o" -exec rm {} \;
132 find ${D}${PTEST_PATH}/ -name "*.h" -exec rm {} \;
133}
134
135INITSCRIPT_NAME = "openhpid"
136INITSCRIPT_PARAMS = "start 30 . stop 70 0 1 2 3 4 5 6 ."
137
Patrick Williams213cb262021-08-07 19:21:33 -0500138SYSTEMD_SERVICE:${PN} = "openhpid.service"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -0800139SYSTEMD_AUTO_ENABLE = "disable"