blob: 479b98d44dc15a64edc0c49ca5543f3fcd342d51 [file] [log] [blame]
Brad Bishop26bdd442019-08-16 17:08:17 -04001SUMMARY = "A text-based user interface plugin of dnf for user to manage packages. "
Andrew Geissler9aee5002022-03-30 16:27:02 +00002LICENSE = "GPL-2.0-only"
Brad Bishop26bdd442019-08-16 17:08:17 -04003
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
Andrew Geissler595f6302022-01-24 19:11:47 +00006SRC_URI = "git://github.com/ubinux/dnf-plugin-tui.git;branch=master;protocol=https"
Patrick Williams03514f12024-04-05 07:04:11 -05007SRCREV = "ad48d934c54ab01026634c90f47f151f148b8147"
Brad Bishop26bdd442019-08-16 17:08:17 -04008
Patrick Williams213cb262021-08-07 19:21:33 -05009SRC_URI:append:class-target = " file://oe-remote.repo.sample"
Brad Bishop26bdd442019-08-16 17:08:17 -040010
Andrew Geissler595f6302022-01-24 19:11:47 +000011inherit setuptools3-base
Brad Bishop26bdd442019-08-16 17:08:17 -040012
13S = "${WORKDIR}/git"
14
Patrick Williams213cb262021-08-07 19:21:33 -050015do_install:append() {
Brad Bishop90ca7472019-08-20 09:15:15 -040016 install -d ${D}${datadir}/dnf
17 install -m 0755 ${S}/samples/* ${D}${datadir}/dnf
18 install -d ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg
19 install -m 0755 ${S}/dnf-plugins/mkimg/* ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins/mkimg
20 for file in $(ls ${S}/dnf-plugins/ | grep -v mkimg); do
21 install -m 0755 ${S}/dnf-plugins/$file ${D}${PYTHON_SITEPACKAGES_DIR}/dnf-plugins
22 done
Brad Bishop26bdd442019-08-16 17:08:17 -040023}
24
Patrick Williams213cb262021-08-07 19:21:33 -050025do_install:append:class-target() {
Brad Bishop90ca7472019-08-20 09:15:15 -040026 install -d ${D}${sysconfdir}/yum.repos.d
27 install -m 0644 ${WORKDIR}/oe-remote.repo.sample ${D}${sysconfdir}/yum.repos.d
Brad Bishop26bdd442019-08-16 17:08:17 -040028}
29
Patrick Williams92b42cb2022-09-03 06:53:57 -050030do_install:append:class-nativesdk() {
31 install -d -p ${D}/${SDKPATH}/postinst-intercepts
32 cp -r ${COREBASE}/scripts/postinst-intercepts/* ${D}/${SDKPATH}/postinst-intercepts/
33 sed -i -e 's/STAGING_DIR_NATIVE/NATIVE_ROOT/g' ${D}/${SDKPATH}/postinst-intercepts/*
34}
35
Patrick Williams213cb262021-08-07 19:21:33 -050036FILES:${PN} += "${datadir}/dnf"
Patrick Williams92b42cb2022-09-03 06:53:57 -050037FILES:${PN} += "${SDKPATH}/postinst-intercepts"
Brad Bishop26bdd442019-08-16 17:08:17 -040038
Patrick Williams213cb262021-08-07 19:21:33 -050039RDEPENDS:${PN} += " \
Brad Bishop90ca7472019-08-20 09:15:15 -040040 bash \
41 dnf \
42 libnewt-python \
43"
Brad Bishop26bdd442019-08-16 17:08:17 -040044BBCLASSEXTEND = "nativesdk"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060045
Andrew Geissler7e0e3c02022-02-25 20:34:39 +000046SKIP_RECIPE[dnf-plugin-tui] ?= "${@bb.utils.contains('PACKAGE_CLASSES', 'package_rpm', '', 'does not build correctly without package_rpm in PACKAGE_CLASSES', d)}"