Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 1 | SUMMARY = "A fast, pure Python library for parsing and serializing ASN.1 structures" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 2 | HOMEPAGE = "https://github.com/wbond/asn1crypto" |
| 3 | SECTION = "devel/python" |
| 4 | LICENSE = "MIT" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b5cda97fbd7959ad47a952651a87051a" |
| 6 | |
| 7 | PYPI_PACKAGE = "asn1crypto" |
| 8 | |
| 9 | SRC_URI[sha256sum] = "13ae38502be632115abf8a24cbe5f4da52e3b5231990aff31123c805306ccb9c" |
| 10 | |
| 11 | inherit pypi setuptools3 |
| 12 | |
| 13 | RDEPENDS:${PN}:class-target += " \ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 14 | python3-codecs \ |
| 15 | python3-crypt \ |
| 16 | python3-ctypes \ |
| 17 | python3-datetime \ |
| 18 | python3-io \ |
| 19 | python3-netclient \ |
| 20 | python3-numbers \ |
| 21 | python3-shell \ |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 22 | " |
| 23 | |
| 24 | BBCLASSEXTEND = "native nativesdk" |