Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 1 | SUMMARY = "YAML parser/emitter that supports roundtrip preservation of comments, seq/map flow style, and map key order." |
| 2 | HOMEPAGE = "https://pypi.org/project/ruamel.yaml/" |
| 3 | |
| 4 | LICENSE = "MIT" |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=30cbbccd94bf3a2b0285ec35671a1938" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 6 | |
| 7 | PYPI_PACKAGE = "ruamel.yaml" |
| 8 | |
| 9 | inherit pypi setuptools3 |
| 10 | |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 11 | SRC_URI[sha256sum] = "8b27e6a217e786c6fbe5634d8f3f11bc63e0f80f6a5890f28863d9c45aac311b" |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 12 | |
| 13 | RDEPENDS:${PN} += "\ |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 14 | python3-shell \ |
| 15 | python3-datetime \ |
| 16 | python3-netclient \ |
Patrick Williams | ac13d5f | 2023-11-24 18:59:46 -0600 | [diff] [blame] | 17 | " |
| 18 | |
| 19 | do_install:prepend() { |
| 20 | export RUAMEL_NO_PIP_INSTALL_CHECK=1 |
| 21 | } |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |