Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 1 | SUMMARY = "PNG image format decoding library" |
| 2 | DESCRIPTION = "An open source project to develop and maintain the reference \ |
| 3 | library for use in applications that read, create, and manipulate PNG \ |
| 4 | (Portable Network Graphics) raster image files. " |
| 5 | HOMEPAGE = "http://www.libpng.org/" |
| 6 | SECTION = "libs" |
| 7 | LICENSE = "Libpng" |
Patrick Williams | 73bd93f | 2024-02-20 08:07:48 -0600 | [diff] [blame] | 8 | LIC_FILES_CHKSUM = "file://LICENSE;md5=0fdbfbe10fc294a6fca24dc76134222a" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 9 | DEPENDS = "zlib" |
| 10 | |
| 11 | LIBV = "16" |
| 12 | |
Patrick Williams | 44b3caf | 2024-04-12 16:51:14 -0500 | [diff] [blame] | 13 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}${LIBV}/${BP}.tar.xz" |
| 14 | SRC_URI[sha256sum] = "6a5ca0652392a2d7c9db2ae5b40210843c0bbc081cbd410825ab00cc59f14a6c" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 15 | |
Patrick Williams | b58112e | 2024-03-07 11:16:36 -0600 | [diff] [blame] | 16 | MIRRORS += "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}${LIBV}/ ${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}${LIBV}/older-releases/" |
Andrew Geissler | 517393d | 2023-01-13 08:55:19 -0600 | [diff] [blame] | 17 | |
| 18 | UPSTREAM_CHECK_URI = "http://libpng.org/pub/png/libpng.html" |
| 19 | |
| 20 | BINCONFIG = "${bindir}/libpng-config ${bindir}/libpng16-config" |
| 21 | |
| 22 | inherit autotools binconfig-disabled pkgconfig |
| 23 | |
| 24 | # Work around missing symbols |
| 25 | ARMNEON = "${@bb.utils.contains("TUNE_FEATURES", "neon", "--enable-arm-neon=on", "--enable-arm-neon=off", d)}" |
| 26 | ARMNEON:aarch64 = "--enable-hardware-optimizations=on" |
| 27 | EXTRA_OECONF += "${ARMNEON}" |
| 28 | |
| 29 | PACKAGES =+ "${PN}-tools" |
| 30 | |
| 31 | FILES:${PN}-tools = "${bindir}/png-fix-itxt ${bindir}/pngfix ${bindir}/pngcp" |
| 32 | |
| 33 | BBCLASSEXTEND = "native nativesdk" |