blob: 6dd7fae570e208eb4c7f6c5b84fd432b6fb0fa5d [file] [log] [blame]
Joel Stanley7259c7d2019-11-04 23:43:51 +10301SUMMARY = "eCMD"
2DESCRIPTION = "eCMD is a hardware access API for IBM Systems"
3LICENSE= "Apache-2.0"
4LIC_FILES_CHKSUM = "file://${S}/NOTICE;md5=fee220301a2af3faf8f211524b4248ea"
5
6SRC_URI = "git://github.com/open-power/eCMD.git"
Joel Stanleyac6d51c2020-01-03 13:53:18 +11007SRCREV = "b858b2f212bda2665ad41e821302e8196c7aec07"
Brad Bishopb3fceb32020-01-17 11:14:37 -05008DEPENDS += "zlib"
Joel Stanley7259c7d2019-11-04 23:43:51 +10309
Joel Stanley5f2105b2019-11-05 11:25:16 +103010SRC_URI += "file://croserver.service"
11
Joel Stanley7259c7d2019-11-04 23:43:51 +103012S = "${WORKDIR}/git"
13
Patrick Williams037f7bd2020-04-01 17:15:38 -050014inherit python3native
Brad Bishopb3fceb32020-01-17 11:14:37 -050015
Joel Stanley7259c7d2019-11-04 23:43:51 +103016do_configure() {
Patrick Williams037f7bd2020-04-01 17:15:38 -050017 LD="${CXX}" ${PYTHON} ${S}/config.py \
18 --without-swig --output-root ${B} --target obj \
19 --extensions "cmd cip" --build-verbose
Joel Stanley7259c7d2019-11-04 23:43:51 +103020}
21
22do_compile() {
23 cd ${S}/dllNetwork/server
24 oe_runmake
25}
26
27do_install() {
28 install -d ${D}${bindir}
29 install -m 0755 out_obj/lib/server1p ${D}${bindir}/croserver
Joel Stanley5f2105b2019-11-05 11:25:16 +103030
31 install -d ${D}${systemd_system_unitdir}
32 install -m 0644 ${WORKDIR}/croserver.service ${D}${systemd_system_unitdir}/
Joel Stanley7259c7d2019-11-04 23:43:51 +103033}
Joel Stanley5f2105b2019-11-05 11:25:16 +103034
35FILES_${PN} += "${systemd_system_unitdir}/croserver.service"