Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | # TODO: include debian's mtp-tools man page (needs xsltproc-native and |
| 2 | # docbook-xsl-native, or we pregenerate it), add support for doxygen |
| 3 | # generation fully with -natives |
| 4 | DESCRIPTION = "libmtp is an Initiator implementation of the Media Transfer \ |
| 5 | Protocol (MTP) in the form of a library suitable primarily for POSIX \ |
| 6 | compliant operating systems" |
| 7 | SUMMARY = "libmtp is an Initiator implementation of the Media Transfer Protocol (MTP)" |
| 8 | HOMEPAGE = "http://libmtp.sourceforge.net/" |
Andrew Geissler | 9aee500 | 2022-03-30 16:27:02 +0000 | [diff] [blame] | 9 | LICENSE = "LGPL-2.1-or-later" |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame^] | 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=0448d3676bc0de00406af227d341a4d1 \ |
| 11 | file://src/ptp.c;beginline=3;endline=22;md5=80fd2d5904c4c1f5455d8f4bf515292f \ |
| 12 | file://examples/albums.c;beginline=5;endline=21;md5=84f4e55dfec49e898b7f68a828c15620 \ |
| 13 | " |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 14 | |
| 15 | BBCLASSEXTEND = "native" |
| 16 | |
| 17 | DEPENDS = "libusb1 gettext-native" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 18 | DEPENDS:append:class-target = " ${BPN}-native" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 19 | |
| 20 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}-${PV}.tar.gz" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 21 | SRC_URI:append:class-target = " file://0001-Use-native-mtp-hotplug.patch" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 22 | |
Patrick Williams | 03907ee | 2022-05-01 06:28:52 -0500 | [diff] [blame^] | 23 | SRC_URI[sha256sum] = "deb4af6f63f5e71215cfa7fb961795262920b4ec6cb4b627f55b30b18aa33228" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | |
| 25 | inherit autotools pkgconfig lib_package |
| 26 | |
| 27 | EXTRA_OECONF += " \ |
| 28 | --disable-rpath \ |
| 29 | --with-udev=${nonarch_base_libdir}/udev \ |
| 30 | " |
| 31 | |
| 32 | PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'largefile', d)}" |
| 33 | PACKAGECONFIG[doxygen] = "--enable-doxygen,--disable-doxygen" |
| 34 | PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile" |
| 35 | PACKAGECONFIG[mtpz] = "--enable-mtpz,--disable-mtpz,libgcrypt" |
| 36 | |
| 37 | PACKAGES =+ "${BPN}-common ${BPN}-runtime" |
| 38 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 39 | RDEPENDS:${BPN} += "libmtp-common" |
| 40 | RRECOMMENDS:${BPN} += "libmtp-runtime ${PN}-bin" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 41 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 42 | FILES:${BPN}-common = "${nonarch_base_libdir}/udev/rules.d/*" |
| 43 | SUMMARY:${BPN}-common = "The udev rules file for MTP devices" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 44 | |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 45 | FILES:${BPN}-runtime = "${nonarch_base_libdir}/udev/mtp-probe" |
| 46 | RDEPENDS:${BPN}-runtime = "libmtp-common" |
| 47 | SUMMARY:${BPN}-runtime = "mtp-probe, used for the MTP udev rules" |
| 48 | DESCRIPTION:${BPN}-runtime = "This package provides mtp-probe, a program to probe newly connected device interfaces from userspace to determine if they are MTP devices, used for udev rules." |