Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | require gmp.inc |
| 2 | |
| 3 | LICENSE = "GPLv2+ | LGPLv3+" |
| 4 | |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \ |
| 6 | file://COPYING.LESSERv3;md5=6a6a8e020838b23406c81b19c1d46df6 \ |
| 7 | file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ |
| 8 | " |
| 9 | |
| 10 | REVISION = "" |
| 11 | SRC_URI = "https://gmplib.org/download/${BPN}/${BP}${REVISION}.tar.bz2 \ |
| 12 | file://use-includedir.patch \ |
| 13 | file://0001-Append-the-user-provided-flags-to-the-auto-detected-.patch \ |
| 14 | file://0001-confiure.ac-Believe-the-cflags-from-environment.patch \ |
| 15 | " |
| 16 | SRC_URI[md5sum] = "c24161e0dd44cae78cd5f67193492a21" |
| 17 | SRC_URI[sha256sum] = "f51c99cb114deb21a60075ffb494c1a210eb9d7cb729ed042ddb7de9534451ea" |
| 18 | |
| 19 | acpaths = "" |
| 20 | |
| 21 | EXTRA_OECONF += " --enable-cxx=detect" |
| 22 | EXTRA_OECONF_mipsarchr6_append = " --disable-assembly" |
| 23 | |
| 24 | PACKAGES =+ "libgmpxx" |
| 25 | FILES_libgmpxx = "${libdir}/libgmpxx${SOLIBS}" |
| 26 | |
| 27 | do_install_append() { |
| 28 | oe_multilib_header gmp.h |
| 29 | } |
| 30 | |
| 31 | do_install_prepend_class-target() { |
| 32 | sed -i \ |
| 33 | -e "s|--sysroot=${STAGING_DIR_HOST}||g" \ |
| 34 | -e "s|${DEBUG_PREFIX_MAP}||g" \ |
| 35 | ${B}/gmp.h |
| 36 | } |
| 37 | |
| 38 | SSTATE_SCAN_FILES += "gmp.h" |
| 39 | |
| 40 | # Doesn't compile in MIPS16e mode due to use of hand-written |
| 41 | # assembly |
| 42 | MIPS_INSTRUCTION_SET = "mips" |
| 43 | |
| 44 | BBCLASSEXTEND = "native nativesdk" |