Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "Library for sending desktop notifications to a notification daemon" |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | DESCRIPTION = "It sends desktop notifications to a notification daemon, as defined \ |
| 3 | in the Desktop Notifications spec. These notifications can be used to inform \ |
| 4 | the user about an event or display some form of information without getting \ |
| 5 | in the user's way." |
Brad Bishop | 64c979e | 2019-11-04 13:55:29 -0500 | [diff] [blame] | 6 | HOMEPAGE = "https://gitlab.gnome.org/GNOME/libnotify" |
| 7 | BUGTRACKER = "https://gitlab.gnome.org/GNOME/libnotify/issues" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 8 | SECTION = "libs" |
| 9 | LICENSE = "LGPLv2.1" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34" |
| 11 | |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 12 | DEPENDS = "dbus glib-2.0 gdk-pixbuf" |
| 13 | |
| 14 | PACKAGECONFIG ?= "" |
| 15 | PACKAGECONFIG[tests] = "-Dtests=true,-Dtests=false,gtk+3" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 16 | |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 17 | GNOMEBASEBUILDCLASS = "meson" |
| 18 | GTKDOC_MESON_OPTION = "gtk_doc" |
| 19 | GIR_MESON_ENABLE_FLAG = "enabled" |
| 20 | GIR_MESON_DISABLE_FLAG = "disabled" |
Brad Bishop | 6dbb316 | 2019-11-25 09:41:34 -0500 | [diff] [blame] | 21 | inherit gnomebase gtk-doc features_check gobject-introspection |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 22 | # depends on gtk+3 if tests are enabled |
| 23 | ANY_OF_DISTRO_FEATURES = "${@bb.utils.contains('PACKAGECONFIG', 'tests', '${GTK3DISTROFEATURES}', '', d)}" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 24 | |
Andrew Geissler | 4b740dc | 2020-05-05 08:54:39 -0500 | [diff] [blame] | 25 | SRC_URI[archive.md5sum] = "ccd9c53364174cc8d13e18a1988faa76" |
| 26 | SRC_URI[archive.sha256sum] = "66c0517ed16df7af258e83208faaf5069727dfd66995c4bbc51c16954d674761" |
| 27 | |
| 28 | EXTRA_OEMESON = "-Dman=false" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 29 | |
| 30 | # there were times, we had two versions of libnotify (oe-core libnotify:0.6.x / |
| 31 | # meta-gnome libnotify3: 0.7.x) |
| 32 | PROVIDES += "libnotify3" |
Patrick Williams | 213cb26 | 2021-08-07 19:21:33 -0500 | [diff] [blame] | 33 | RPROVIDES:${PN} += "libnotify3" |
| 34 | RCONFLICTS:${PN} += "libnotify3" |
| 35 | RREPLACES:${PN} += "libnotify3" |
William A. Kennington III | ac69b48 | 2021-06-02 12:28:27 -0700 | [diff] [blame] | 36 | |
| 37 | # -7381 is specific to the NodeJS bindings |
| 38 | CVE_CHECK_WHITELIST += "CVE-2013-7381" |