Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 1 | SUMMARY = "Subversion (svn) version control system client" |
| 2 | SECTION = "console/network" |
| 3 | DEPENDS = "apr-util serf sqlite3 file" |
| 4 | DEPENDS_append_class-native = " file-replacement-native" |
| 5 | RDEPENDS_${PN} = "serf" |
| 6 | LICENSE = "Apache-2" |
| 7 | HOMEPAGE = "http://subversion.tigris.org" |
| 8 | |
| 9 | BBCLASSEXTEND = "native" |
| 10 | |
| 11 | inherit gettext pkgconfig |
| 12 | |
| 13 | SRC_URI = "${APACHE_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \ |
| 14 | file://disable_macos.patch \ |
| 15 | file://serf.m4-Regex-modified-to-allow-D-in-paths.patch \ |
| 16 | file://0001-Fix-libtool-name-in-configure.ac.patch \ |
| 17 | file://serfmacro.patch \ |
| 18 | " |
| 19 | |
| 20 | SRC_URI[md5sum] = "05b0c677681073920f938c1f322e0be2" |
| 21 | SRC_URI[sha256sum] = "c3b118333ce12e501d509e66bb0a47bcc34d053990acab45559431ac3e491623" |
| 22 | |
| 23 | LIC_FILES_CHKSUM = "file://LICENSE;md5=af81ae49ba359e70626c05e9bf313709" |
| 24 | |
| 25 | PACKAGECONFIG[sasl] = "--with-sasl,--without-sasl,cyrus-sasl" |
| 26 | PACKAGECONFIG[gnome-keyring] = "--with-gnome-keyring,--without-gnome-keyring,glib-2.0 gnome-keyring" |
| 27 | |
| 28 | EXTRA_OECONF = " \ |
| 29 | --without-berkeley-db --without-apxs \ |
| 30 | --without-swig --with-apr=${STAGING_BINDIR_CROSS} \ |
| 31 | --with-apr-util=${STAGING_BINDIR_CROSS} \ |
| 32 | --disable-keychain \ |
| 33 | ac_cv_path_RUBY=none" |
| 34 | |
| 35 | inherit autotools |
| 36 | |
| 37 | export LDFLAGS += " -L${STAGING_LIBDIR} " |
| 38 | CPPFLAGS += "-P" |
| 39 | BUILD_CPPFLAGS += "-P" |
| 40 | |
| 41 | acpaths = "-I build/ -I build/ac-macros/" |
| 42 | |
| 43 | do_configure_prepend () { |
| 44 | rm -f ${S}/libtool |
| 45 | rm -f ${S}/build/libtool.m4 ${S}/build/ltmain.sh ${S}/build/ltoptions.m4 ${S}/build/ltsugar.m4 ${S}/build/ltversion.m4 ${S}/build/lt~obsolete.m4 |
| 46 | rm -f ${S}/aclocal.m4 |
| 47 | sed -i -e 's:with_sasl="/usr/local":with_sasl="${STAGING_DIR}":' ${S}/build/ac-macros/sasl.m4 |
| 48 | } |
| 49 | |
| 50 | #| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_local/libsvn_ra_local-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| /usr/bin/ld: cannot find -lsvn_delta-1| collect2: ld returned 1 exit status| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_svn/libsvn_ra_svn-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib'| x86_64-linux-libtool: install: warning: `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/build/subversion/libsvn_ra_serf/libsvn_ra_serf-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib' |
| 51 | #| x86_64-linux-libtool: install: error: relink `libsvn_ra_serf-1.la' with the above command before installing it |
| 52 | #| x86_64-linux-libtool: install: warning: `../../subversion/libsvn_repos/libsvn_repos-1.la' has not been installed in `/home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/sysroots/x86_64-linux/usr/lib' |
| 53 | #| /home/pokybuild/yocto-autobuilder/yocto-worker/nightly-qa-logrotate/build/build/tmp/work/x86_64-linux/subversion-native/1.8.9-r0/subversion-1.8.9/build-outputs.mk:1090: recipe for target 'install-serf-lib' failed |
| 54 | #| make: *** [install-serf-lib] Error 1 |
| 55 | PARALLEL_MAKEINST = "" |