Richard Marian Thomaiyar | 14fddef | 2018-07-13 23:55:56 +0530 | [diff] [blame] | 1 | SUMMARY = "Daemon to ban hosts that cause multiple authentication errors." |
| 2 | DESCRIPTION = "Fail2Ban scans log files like /var/log/auth.log and bans IP addresses having too \ |
| 3 | many failed login attempts. It does this by updating system firewall rules to reject new \ |
| 4 | connections from those IP addresses, for a configurable amount of time. Fail2Ban comes \ |
| 5 | out-of-the-box ready to read many standard log files, such as those for sshd and Apache, \ |
| 6 | and is easy to configure to read any log file you choose, for any error you choose." |
| 7 | HOMEPAGE = "http://www.fail2ban.org" |
| 8 | |
| 9 | LICENSE = "GPL-2.0" |
| 10 | LIC_FILES_CHKSUM = "file://COPYING;md5=ecabc31e90311da843753ba772885d9f" |
| 11 | |
| 12 | SRCREV ="a45488465e0dd547eb8479c0fa9fd577c1837213" |
| 13 | SRC_URI = " \ |
| 14 | git://github.com/fail2ban/fail2ban.git;branch=0.10 \ |
| 15 | file://initd \ |
| 16 | file://fail2ban_setup.py \ |
| 17 | " |
| 18 | |
| 19 | inherit update-rc.d setuptools |
| 20 | |
| 21 | S = "${WORKDIR}/git" |
| 22 | |
| 23 | INITSCRIPT_PACKAGES = "${PN}" |
| 24 | INITSCRIPT_NAME = "fail2ban-server" |
| 25 | INITSCRIPT_PARAMS = "defaults 25" |
| 26 | |
| 27 | do_compile_prepend () { |
| 28 | cp ${WORKDIR}/fail2ban_setup.py ${S}/setup.py |
| 29 | } |
| 30 | |
| 31 | do_install_append () { |
| 32 | install -d ${D}/${sysconfdir}/fail2ban |
| 33 | install -d ${D}/${sysconfdir}/init.d |
| 34 | install -m 0755 ${WORKDIR}/initd ${D}${sysconfdir}/init.d/fail2ban-server |
| 35 | } |
| 36 | |
| 37 | FILES_${PN} += "/run" |
| 38 | |
| 39 | INSANE_SKIP_${PN}_append = "already-stripped" |
| 40 | |
| 41 | RDEPENDS_${PN} = "sysklogd iptables sqlite3 python python-pyinotify" |