Brad Bishop | 286d45c | 2018-10-02 15:21:57 -0400 | [diff] [blame] | 1 | SUMMARY = "Control Software for VCU" |
| 2 | DESCRIPTION = "Control software libraries, test applications and headers provider for VCU" |
| 3 | LICENSE = "Proprietary" |
| 4 | LIC_FILES_CHKSUM = "file://LICENSE.md;md5=03a7aef7e6f6a76a59fd9b8ba450b493" |
| 5 | |
| 6 | XILINX_VCU_VERSION = "1.0.0" |
| 7 | XILINX_RELEASE_VERSION = "2018.1" |
| 8 | PV = "${XILINX_VCU_VERSION}-xilinx-${XILINX_RELEASE_VERSION}+git${SRCPV}" |
| 9 | |
| 10 | BRANCH ?= "master" |
| 11 | REPO ?= "git://github.com/xilinx/vcu-ctrl-sw.git;protocol=https" |
| 12 | SRCREV = "aa4b6871346c915f28a069190afec5d30963762f" |
| 13 | |
| 14 | BRANCHARG = "${@['nobranch=1', 'branch=${BRANCH}'][d.getVar('BRANCH', True) != '']}" |
| 15 | SRC_URI = "${REPO};${BRANCHARG}" |
| 16 | |
| 17 | S = "${WORKDIR}/git" |
| 18 | |
| 19 | COMPATIBLE_MACHINE = "^$" |
| 20 | COMPATIBLE_MACHINE_zynqmp = "zynqmp" |
| 21 | |
| 22 | PACKAGE_ARCH = "${SOC_FAMILY}" |
| 23 | |
| 24 | RDEPENDS_${PN} = "kernel-module-vcu" |
| 25 | |
| 26 | EXTRA_OEMAKE = "CC='${CC}' CXX='${CXX} ${CXXFLAGS}'" |
| 27 | |
| 28 | do_install() { |
| 29 | install -d ${D}${libdir} |
| 30 | install -d ${D}${includedir}/vcu-ctrl-sw/include |
| 31 | |
| 32 | install -Dm 0755 ${S}/bin/AL_Encoder.exe ${D}/${bindir}/AL_Encoder.exe |
| 33 | install -Dm 0755 ${S}/bin/AL_Decoder.exe ${D}/${bindir}/AL_Decoder.exe |
| 34 | |
| 35 | oe_runmake install_headers INSTALL_HDR_PATH=${D}${includedir}/vcu-ctrl-sw/include |
| 36 | oe_libinstall -C ${S}/bin/ -so liballegro_decode ${D}/${libdir}/ |
| 37 | oe_libinstall -C ${S}/bin/ -so liballegro_encode ${D}/${libdir}/ |
| 38 | } |
| 39 | |
| 40 | # These libraries shouldn't get installed in world builds unless something |
| 41 | # explicitly depends upon them. |
| 42 | |
| 43 | EXCLUDE_FROM_WORLD = "1" |