Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 1 | # Helper class to pull in the right gtk-doc dependencies and configure |
| 2 | # gtk-doc to enable or disable documentation building (which requries the |
| 3 | # use of usermode qemu). |
| 4 | |
| 5 | # This variable is set to True if api-documentation is in |
| 6 | # DISTRO_FEATURES and qemu-usermode is in MACHINE_FEATURES, and False otherwise. |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 7 | # |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 8 | # It should be used in recipes to determine whether gtk-doc based documentation should be built, |
| 9 | # so that qemu use can be avoided when necessary. |
| 10 | GTKDOC_ENABLED ?= "${@bb.utils.contains('DISTRO_FEATURES', 'api-documentation', \ |
| 11 | bb.utils.contains('MACHINE_FEATURES', 'qemu-usermode', 'True', 'False', d), 'False', d)}" |
| 12 | |
| 13 | EXTRA_OECONF_prepend_class-target = "${@bb.utils.contains('GTKDOC_ENABLED', 'True', '--enable-gtk-doc --enable-gtk-doc-html --disable-gtk-doc-pdf', \ |
| 14 | '--disable-gtk-doc', d)} " |
| 15 | |
| 16 | # When building native recipes, disable gtkdoc, as it is not necessary, |
| 17 | # pulls in additional dependencies, and makes build times longer |
| 18 | EXTRA_OECONF_prepend_class-native = "--disable-gtk-doc " |
| 19 | EXTRA_OECONF_prepend_class-nativesdk = "--disable-gtk-doc " |
| 20 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 21 | # Even though gtkdoc is disabled on -native, gtk-doc package is still |
| 22 | # needed for m4 macros. |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 23 | DEPENDS_append = " gtk-doc-native" |
Patrick Williams | c124f4f | 2015-09-15 14:41:29 -0500 | [diff] [blame] | 24 | |
| 25 | # The documentation directory, where the infrastructure will be copied. |
| 26 | # gtkdocize has a default of "." so to handle out-of-tree builds set this to $S. |
| 27 | GTKDOC_DOCDIR ?= "${S}" |
| 28 | |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 29 | export STAGING_DIR_HOST |
| 30 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 31 | inherit python3native pkgconfig qemu |
| 32 | DEPENDS_append = "${@' qemu-native' if d.getVar('GTKDOC_ENABLED') == 'True' else ''}" |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 33 | |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 34 | do_configure_prepend () { |
| 35 | # Need to use ||true as this is only needed if configure.ac both exists |
| 36 | # and uses GTK_DOC_CHECK. |
| 37 | gtkdocize --srcdir ${S} --docdir ${GTKDOC_DOCDIR} || true |
| 38 | } |
| 39 | |
| 40 | do_compile_prepend_class-target () { |
| 41 | if [ ${GTKDOC_ENABLED} = True ]; then |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 42 | # Write out a qemu wrapper that will be given to gtkdoc-scangobj so that it |
| 43 | # can run target helper binaries through that. |
| 44 | qemu_binary="${@qemu_wrapper_cmdline(d, '$STAGING_DIR_HOST', ['\$GIR_EXTRA_LIBS_PATH','$STAGING_DIR_HOST/${libdir}','$STAGING_DIR_HOST/${base_libdir}'])}" |
| 45 | cat > ${B}/gtkdoc-qemuwrapper << EOF |
| 46 | #!/bin/sh |
| 47 | # Use a modules directory which doesn't exist so we don't load random things |
| 48 | # which may then get deleted (or their dependencies) and potentially segfault |
| 49 | export GIO_MODULE_DIR=${STAGING_LIBDIR}/gio/modules-dummy |
| 50 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 51 | GIR_EXTRA_LIBS_PATH=\`find ${B} -name *.so -printf "%h\n"|sort|uniq| tr '\n' ':'\`\$GIR_EXTRA_LIBS_PATH |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 52 | GIR_EXTRA_LIBS_PATH=\`find ${B} -name .libs| tr '\n' ':'\`\$GIR_EXTRA_LIBS_PATH |
| 53 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 54 | if [ -d ".libs" ]; then |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 55 | $qemu_binary ".libs/\$@" |
| 56 | else |
| 57 | $qemu_binary "\$@" |
| 58 | fi |
| 59 | |
| 60 | if [ \$? -ne 0 ]; then |
| 61 | echo "If the above error message is about missing .so libraries, then setting up GIR_EXTRA_LIBS_PATH in the recipe should help." |
| 62 | echo "(typically like this: GIR_EXTRA_LIBS_PATH=\"$""{B}/something/.libs\" )" |
| 63 | exit 1 |
| 64 | fi |
| 65 | EOF |
| 66 | chmod +x ${B}/gtkdoc-qemuwrapper |
Brad Bishop | 316dfdd | 2018-06-25 12:45:53 -0400 | [diff] [blame] | 67 | fi |
Patrick Williams | c0f7c04 | 2017-02-23 20:41:17 -0600 | [diff] [blame] | 68 | } |