Andrew Geissler | 87f5cff | 2022-09-30 13:13:31 -0500 | [diff] [blame] | 1 | SUMMARY = "Open-LLDP" |
| 2 | DESCRIPTION = "Link Layer Discovery Protocol for Linux that includes support for DCBX" |
| 3 | HOMEPAGE = "http://open-lldp.org/start" |
| 4 | |
| 5 | LICENSE = "GPL-2.0-only" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=8c2bc283e65df398ced5f5b747e78162" |
| 7 | |
| 8 | S = "${WORKDIR}/git" |
| 9 | |
| 10 | inherit pkgconfig autotools |
| 11 | inherit ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)} |
| 12 | |
| 13 | DEPENDS = "libnl libconfig readline" |
| 14 | |
| 15 | SRCREV = "85e55837a81d710e5baa7da47f7ed0d205c8ede5" |
| 16 | PV .= "+git${SRCPV}" |
| 17 | SRC_URI = "git://github.com/intel/openlldp.git;protocol=https;branch=branch-1.1 \ |
| 18 | file://0001-Fix-musl-libc-build-issue.patch \ |
| 19 | file://0001-autotools-Add-include-path-to-generated-version.h.patch \ |
| 20 | file://0001-autotools-Add-option-to-disable-installation-of-syst.patch \ |
| 21 | file://0004-clif-Include-string.h-for-mem-function-prototypes.patch \ |
| 22 | " |
| 23 | |
| 24 | # Enable install of systemd conf files. |
| 25 | EXTRA_OECONF += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemdsystemunitdir=${systemd_system_unitdir}', '', d)}" |
| 26 | |
| 27 | SYSTEMD_SERVICE:${PN} = "lldpad.service lldpad.socket" |
| 28 | |
| 29 | # To enable service at boot set to enable in local.conf. |
| 30 | SYSTEMD_AUTO_ENABLE ?= "disable" |
| 31 | |
| 32 | RRECOMMENDS:${PN} = "iproute2-tc" |