Lei YU | 7307bed | 2020-02-06 15:43:35 +0800 | [diff] [blame] | 1 | SUMMARY = "Phosphor Power Sequencer services installation" |
Lei YU | 7307bed | 2020-02-06 15:43:35 +0800 | [diff] [blame] | 2 | LICENSE = "Apache-2.0" |
| 3 | LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10" |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 4 | PR = "r1" |
Lei YU | 7307bed | 2020-02-06 15:43:35 +0800 | [diff] [blame] | 5 | |
| 6 | inherit allarch |
| 7 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 8 | RDEPENDS:${PN} += "phosphor-power-sequencer" |
Lei YU | 7307bed | 2020-02-06 15:43:35 +0800 | [diff] [blame] | 9 | |
Patrick Williams | 12fc939 | 2021-08-06 09:16:53 -0500 | [diff] [blame] | 10 | pkg_prerm:${PN}() { |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 11 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor.service" |
| 12 | rm $LINK |
| 13 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor-pgood.service" |
| 14 | rm $LINK |
Lei YU | 7307bed | 2020-02-06 15:43:35 +0800 | [diff] [blame] | 15 | } |
Ed Tanous | 9936f86 | 2022-09-19 09:13:20 -0700 | [diff] [blame] | 16 | pkg_postinst:${PN}() { |
| 17 | mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants |
| 18 | mkdir -p $D$systemd_system_unitdir/multi-user.target.requires |
| 19 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor.service" |
| 20 | TARGET="../pseq-monitor.service" |
| 21 | ln -s $TARGET $LINK |
| 22 | LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.wants/pseq-monitor-pgood.service" |
| 23 | TARGET="../pseq-monitor-pgood.service" |
| 24 | ln -s $TARGET $LINK |
| 25 | } |
| 26 | |
| 27 | ALLOW_EMPTY:${PN} = "1" |