blob: 3f8fe2f360719ba96827f76f32770ebaa14a49aa [file] [log] [blame]
Brad Bishope42b3e32020-01-15 22:08:42 -05001SUMMARY = "Linux libcamera framework"
2SECTION = "libs"
3
4LICENSE = "GPL-2.0 & LGPL-2.1"
5
6LIC_FILES_CHKSUM = "\
7 file://licenses/gnu-gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://licenses/gnu-lgpl-2.1.txt;md5=4b54a1fd55a448865a0b32d41598759d \
9"
10
11SRC_URI = " \
12 git://linuxtv.org/libcamera.git;protocol=git \
Brad Bishope42b3e32020-01-15 22:08:42 -050013"
14
Andrew Geissler82c905d2020-04-13 13:39:40 -050015SRCREV = "a8be6e94e79f602d543a15afd44ef60e378b138f"
Brad Bishope42b3e32020-01-15 22:08:42 -050016
Andrew Geissler82c905d2020-04-13 13:39:40 -050017PV = "202002+git${SRCPV}"
Brad Bishope42b3e32020-01-15 22:08:42 -050018
19S = "${WORKDIR}/git"
20
21DEPENDS = "python3-pyyaml-native udev"
22DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'qt', 'qtbase qtbase-native', '', d)}"
23
24RDEPENDS_${PN} = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland qt', 'qtwayland', '', d)}"
25
26inherit meson pkgconfig python3native
27
28FILES_${PN}-dev = "${includedir} ${libdir}/pkgconfig"
29FILES_${PN} += " ${libdir}/libcamera.so"
30