Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 1 | SUMMARY = "interface to seccomp filtering mechanism" |
| 2 | DESCRIPTION = "The libseccomp library provides and easy to use, platform independent,interface to the Linux Kernel's syscall filtering mechanism: seccomp." |
| 3 | SECTION = "security" |
| 4 | LICENSE = "LGPL-2.1" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE;beginline=0;endline=1;md5=8eac08d22113880357ceb8e7c37f989f" |
| 6 | |
Andrew Geissler | 1fe918a | 2020-05-15 14:16:47 -0500 | [diff] [blame] | 7 | SRCREV = "1dde9d94e0848e12da20602ca38032b91d521427" |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 8 | |
| 9 | SRC_URI = "git://github.com/seccomp/libseccomp.git;branch=release-2.4 \ |
| 10 | file://run-ptest \ |
| 11 | " |
| 12 | |
| 13 | S = "${WORKDIR}/git" |
| 14 | |
| 15 | inherit autotools-brokensep pkgconfig ptest |
| 16 | |
| 17 | PACKAGECONFIG ??= "" |
| 18 | PACKAGECONFIG[python] = "--enable-python, --disable-python, python" |
| 19 | |
Brad Bishop | 1fdf4aa | 2019-09-09 14:56:41 -0400 | [diff] [blame] | 20 | DISABLE_STATIC = "" |
| 21 | |
Brad Bishop | c342db3 | 2019-05-15 21:57:59 -0400 | [diff] [blame] | 22 | do_compile_ptest() { |
| 23 | oe_runmake -C tests check-build |
| 24 | } |
| 25 | |
| 26 | do_install_ptest() { |
| 27 | install -d ${D}${PTEST_PATH}/tests |
| 28 | install -d ${D}${PTEST_PATH}/tools |
| 29 | for file in $(find tests/* -executable -type f); do |
| 30 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 31 | done |
| 32 | for file in $(find tests/*.tests -type f); do |
| 33 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tests |
| 34 | done |
| 35 | for file in $(find tools/* -executable -type f); do |
| 36 | install -m 744 ${S}/${file} ${D}/${PTEST_PATH}/tools |
| 37 | done |
| 38 | } |
| 39 | |
| 40 | FILES_${PN} = "${bindir} ${libdir}/${BPN}.so*" |
| 41 | FILES_${PN}-dbg += "${libdir}/${PN}/tests/.debug/* ${libdir}/${PN}/tools/.debug" |
| 42 | |
| 43 | RDEPENDS_${PN}-ptest = "bash" |