blob: 776116299727277838473cfd8f79c755df985b3f [file] [log] [blame]
Ed Tanous2c2a1c52018-01-29 10:56:52 -08001LICENSE = "Apache-2.0"
Andrew Geisslere11f5e22021-07-20 18:10:59 +00002LIC_FILES_CHKSUM = "file://LICENSE;md5=175792518e4ac015ab6696d16c4f607e"
Ed Tanous07f48cc2021-02-22 10:49:30 -08003DEPENDS = " \
Ed Tanous07f48cc2021-02-22 10:49:30 -08004 boost \
Andrew Geissler82b9d022024-08-26 15:40:51 -05005 cli11 \
Ed Tanous07f48cc2021-02-22 10:49:30 -08006 gtest \
Andrew Geissler82b9d022024-08-26 15:40:51 -05007 libpam \
Ed Tanous07f48cc2021-02-22 10:49:30 -08008 libtinyxml2 \
Ed Tanousa994d3a2021-06-16 12:44:37 -07009 nghttp2 \
Andrew Geissler82b9d022024-08-26 15:40:51 -050010 nlohmann-json \
11 openssl \
12 sdbusplus \
13 zlib \
Ed Tanousa443c542021-02-26 13:28:37 -080014 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gtest', '', d)} \
15 ${@bb.utils.contains('PTEST_ENABLED', '1', 'gmock', '', d)} \
Ed Tanous07f48cc2021-02-22 10:49:30 -080016"
Andrew Geissler31f45c62024-09-16 10:50:47 -050017SRCREV = "d51c61b4b7b57cf1b662f03dc99819bf025f283a"
Ed Tanous9936f862022-09-19 09:13:20 -070018PV = "1.0+git${SRCPV}"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080019
Patrick Williams0b73b982023-01-26 10:24:41 -060020SRC_URI = "git://github.com/openbmc/bmcweb.git;branch=master;protocol=https"
Ed Tanous9936f862022-09-19 09:13:20 -070021SRC_URI += " \
22 file://run-ptest \
Ed Tanous07f48cc2021-02-22 10:49:30 -080023"
Adriana Kobylak7e0ff54f2018-12-13 11:01:05 -060024
Ed Tanous9936f862022-09-19 09:13:20 -070025S = "${WORKDIR}/git"
26SYSTEMD_SERVICE:${PN} += "bmcweb.service bmcweb.socket"
Ed Tanousa443c542021-02-26 13:28:37 -080027
Ed Tanous9936f862022-09-19 09:13:20 -070028inherit systemd
29inherit useradd
30inherit pkgconfig meson ptest
Ed Tanous2c2a1c52018-01-29 10:56:52 -080031
Patrick Williams4b5fdfa2024-02-23 09:35:19 -060032PACKAGECONFIG ??= "mutual-tls-auth"
Patrick Williamsa7587522023-06-13 14:43:24 -050033PACKAGECONFIG[insecure-redfish-expand]="-Dinsecure-enable-redfish-query=enabled"
Patrick Williams4b5fdfa2024-02-23 09:35:19 -060034PACKAGECONFIG[mutual-tls-auth]="-Dmutual-tls-auth=enabled,-Dmutual-tls-auth=disabled"
Patrick Williamsa7587522023-06-13 14:43:24 -050035
Andrew Geissler5048d532024-07-14 16:00:31 -050036MUTUAL_TLS_PARSING="CommonName"
Patrick Williamsde59cd52024-02-23 09:46:37 -060037
Ed Tanousa443c542021-02-26 13:28:37 -080038EXTRA_OEMESON = " \
39 --buildtype=minsize \
40 -Dtests=${@bb.utils.contains('PTEST_ENABLED', '1', 'enabled', 'disabled', d)} \
Patrick Williamsde59cd52024-02-23 09:46:37 -060041 ${@bb.utils.contains('PACKAGECONFIG', 'mutual-tls-auth', \
Andrew Geissler5048d532024-07-14 16:00:31 -050042 '-Dmutual-tls-common-name-parsing-default=' + d.getVar('MUTUAL_TLS_PARSING', True), \
Patrick Williamsde59cd52024-02-23 09:46:37 -060043 '', d)} \
Ed Tanousa443c542021-02-26 13:28:37 -080044"
Ed Tanous2c2a1c52018-01-29 10:56:52 -080045
Ed Tanous9936f862022-09-19 09:13:20 -070046do_install_ptest() {
47 install -d ${D}${PTEST_PATH}/test
48 cp -rf ${B}/*_test ${D}${PTEST_PATH}/test/
49}
Ed Tanous2c2a1c52018-01-29 10:56:52 -080050
Ed Tanous9936f862022-09-19 09:13:20 -070051RDEPENDS:${PN} += " \
52 jsnbd \
Patrick Williams0450a022022-10-07 21:23:47 -050053 phosphor-objmgr \
Ed Tanous9936f862022-09-19 09:13:20 -070054"
55
56FILES:${PN} += "${datadir}/** "
57
58USERADD_PACKAGES = "${PN}"
59# add a user called httpd for the server to assume
60USERADD_PARAM:${PN} = "-r -s /sbin/nologin bmcweb"
61
Ninad Palsule34d21442023-03-09 10:20:38 -060062GROUPADD_PARAM:${PN} = "web; redfish; hostconsole"
Andrew Jeffery224f26f2023-03-10 12:38:57 +103063FULL_OPTIMIZATION:append = " -Os"