Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "download online streams into audio files" |
| 2 | DESCRIPTION = "This command-line tool can be used to record MPEG III \ |
| 3 | and OGG online radio-streams into track-separated audio files." |
| 4 | HOMEPAGE = "http://streamripper.sourceforge.net" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" |
| 7 | DEPENDS = "glib-2.0 libmad libogg libvorbis" |
| 8 | |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 9 | # While this item does not require it, it depends on libmad which does |
| 10 | LICENSE_FLAGS = "commercial" |
| 11 | |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 12 | SRC_URI = "\ |
| 13 | ${SOURCEFORGE_MIRROR}/${BPN}/${BP}.tar.gz \ |
| 14 | file://0001-build-these-are-foreign-automake-projects.patch \ |
| 15 | file://0002-build-don-t-ignore-CPPFLAGS-from-environment.patch \ |
| 16 | file://0003-ripstream-fix-compilation.patch \ |
| 17 | " |
| 18 | SRC_URI[mdsum] = "a37a1a8b8f9228522196a122a1c2dd32" |
| 19 | SRC_URI[sha256sum] = "c1d75f2e9c7b38fd4695be66eff4533395248132f3cc61f375196403c4d8de42" |
| 20 | |
| 21 | inherit autotools pkgconfig |
| 22 | |
| 23 | EXTRA_OECONF += "--with-included-argv=yes --with-included-libmad=no" |
| 24 | EXTRA_OECONF += "\ |
| 25 | --with-ogg-includes=${STAGING_INCDIR} \ |
| 26 | --with-ogg-libraries=${STAGING_LIBDIR} \ |
| 27 | --with-vorbis-includes=${STAGING_INCDIR} \ |
| 28 | --with-vorbis-libraries=${STAGING_LIBDIR} \ |
| 29 | " |
| 30 | |
| 31 | # the included argv library needs this |
| 32 | CPPFLAGS_append = " -DANSI_PROTOTYPES" |