Andrew Geissler | 32b1199 | 2021-03-31 13:37:05 -0500 | [diff] [blame] | 1 | SUMMARY = "Base64 Encoding/Decoding Routines" |
| 2 | DESCRIPTION = "base64 encoding/decoding library - runtime library \ |
| 3 | libb64 is a library of ANSI C routines for fast encoding/decoding data into \ |
| 4 | and from a base64-encoded format" |
| 5 | HOMEPAGE = "http://libb64.sourceforge.net/" |
| 6 | LICENSE = "PD" |
| 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=ce551aad762074c7ab618a0e07a8dca3" |
| 8 | |
| 9 | SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${BPN}/${BP}.zip \ |
| 10 | file://0001-example-Do-not-run-the-tests.patch \ |
| 11 | file://0002-use-BUFSIZ-as-buffer-size.patch \ |
| 12 | file://0003-fix-integer-overflows.patch \ |
| 13 | file://0004-Fix-off-by-one-error.patch \ |
| 14 | file://0005-make-overriding-CFLAGS-possible.patch \ |
| 15 | file://0006-do-not-export-the-CHARS_PER_LINE-variable.patch \ |
| 16 | file://0007-initialize-encoder-decoder-state-in-the-constructors.patch \ |
| 17 | " |
| 18 | SRC_URI[sha256sum] = "20106f0ba95cfd9c35a13c71206643e3fb3e46512df3e2efb2fdbf87116314b2" |
| 19 | |
| 20 | PARALLEL_MAKE = "" |
| 21 | |
| 22 | CFLAGS += "-fPIC" |
| 23 | |
| 24 | do_configure () { |
| 25 | : |
| 26 | } |
| 27 | |
| 28 | do_compile () { |
| 29 | oe_runmake |
| 30 | ${CC} ${LDFLAGS} ${CFLAGS} -shared -Wl,-soname,${BPN}.so.0 src/*.o -o src/${BPN}.so.0 |
| 31 | } |
| 32 | |
| 33 | do_install () { |
| 34 | install -d ${D}${includedir}/b64 |
| 35 | install -Dm 0644 ${B}/src/libb64.a ${D}${libdir}/libb64.a |
| 36 | install -Dm 0644 ${B}/src/libb64.so.0 ${D}${libdir}/libb64.so.0 |
| 37 | ln -s libb64.so.0 ${D}${libdir}/libb64.so |
| 38 | install -Dm 0644 ${S}/include/b64/*.h ${D}${includedir}/b64/ |
| 39 | } |