blob: f493d3aae246ba31b6d0eb71a83d93df589cebf5 [file] [log] [blame]
Andrew Geissler82cfa662020-02-17 15:11:03 -06001SUMMARY = "OpenPOWER processor control services installation"
2PR = "r1"
3
4LICENSE = "Apache-2.0"
5LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
6
7inherit allarch
8
9RDEPENDS_${PN} += "op-proc-control"
10RDEPENDS_${PN} += "phosphor-state-manager-obmc-targets"
11
12ALLOW_EMPTY_${PN} = "1"
13
14pkg_postinst_${PN}() {
Andrew Geissler55bd4492020-03-31 13:43:46 -050015 mkdir -p $D$systemd_system_unitdir/obmc-host-stop@0.target.wants
Andrew Geissler82cfa662020-02-17 15:11:03 -060016 mkdir -p $D$systemd_system_unitdir/obmc-host-force-warm-reboot@0.target.requires
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -050017 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
18 mkdir -p $D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires
Andrew Geisslerf95063e2020-04-14 15:08:43 -050019 mkdir -p $D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires
Andrew Geisslerc3f1beb2020-12-09 15:05:02 -060020 mkdir -p $D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants
Andrew Geissler82cfa662020-02-17 15:11:03 -060021
Andrew Geissler55bd4492020-03-31 13:43:46 -050022 LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -060023 TARGET="../op-stop-instructions@.service"
24 ln -s $TARGET $LINK
25
Andrew Geisslerc3f1beb2020-12-09 15:05:02 -060026 LINK="$D$systemd_system_unitdir/obmc-host-quiesce@0.target.wants/op-stop-instructions@0.service"
27 TARGET="../op-stop-instructions@.service"
28 ln -s $TARGET $LINK
29
Andrew Geisslerf95063e2020-04-14 15:08:43 -050030 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
31 TARGET="../op-cfam-reset.service"
32 ln -s $TARGET $LINK
33
34 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -060035 TARGET="../op-cfam-reset.service"
36 ln -s $TARGET $LINK
Andrew Geissler4e174d12020-02-26 14:11:53 -060037
38 # Only install cfam override if p9 system
39 if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
40 mkdir -p $D$systemd_system_unitdir/obmc-host-startmin@0.target.requires
41 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
42 TARGET="../cfam_override@.service"
43 ln -s $TARGET $LINK
44 fi
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -050045
46 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
47 TARGET="../op-continue-mpreboot@.service"
48 ln -s $TARGET $LINK
49
50 LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
51 TARGET="../op-enter-mpreboot@.service"
52 ln -s $TARGET $LINK
Ramesh Iyyard6d9b542020-09-17 10:02:08 -050053
54 # Only install phal reinit service if phal enabled
55 if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" = phal ]; then
56 mkdir -p $D$systemd_system_unitdir/obmc-host-start@0.target.requires
57 LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
58 TARGET="../phal-reinit-devtree.service"
59 ln -s $TARGET $LINK
Chirag Sharma5ec16a32020-12-11 03:45:15 -060060
61 LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
62 TARGET="../proc-pre-poweroff@.service"
63 ln -s $TARGET $LINK
Ramesh Iyyard6d9b542020-09-17 10:02:08 -050064 fi
Andrew Geissler82cfa662020-02-17 15:11:03 -060065}
66
67pkg_prerm_${PN}() {
Andrew Geissler55bd4492020-03-31 13:43:46 -050068 LINK="$D$systemd_system_unitdir/obmc-host-stop@0.target.wants/op-stop-instructions@0.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -060069 rm $LINK
Andrew Geisslerf95063e2020-04-14 15:08:43 -050070 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-cfam-reset.service"
71 rm $LINK
72 LINK="$D$systemd_system_unitdir/obmc-chassis-poweron@0.target.requires/op-cfam-reset.service"
Andrew Geissler82cfa662020-02-17 15:11:03 -060073 rm $LINK
Andrew Geissler4e174d12020-02-26 14:11:53 -060074 # Only uninstall cfam override if p9 system
75 if [ "${@bb.utils.contains("MACHINE_FEATURES", "p9-cfam-override", "True", "False", d)}" = True ]; then
76 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/cfam_override@0.service"
77 rm $LINK
78 fi
Dhruvaraj Subhashchandranc8aa6a12020-03-09 13:04:32 -050079 LINK="$D$systemd_system_unitdir/obmc-host-startmin@0.target.requires/op-continue-mpreboot@0.service"
80 rm $LINK
81 LINK="$D$systemd_system_unitdir/obmc-host-diagnostic-mode@0.target.requires/op-enter-mpreboot@0.service"
82 rm $LINK
Ramesh Iyyard6d9b542020-09-17 10:02:08 -050083
84 # Only phal reinit service if phal enabled
85 if [ "${@bb.utils.filter('OBMC_MACHINE_FEATURES', 'phal', d)}" = phal ]; then
86 LINK="$D$systemd_system_unitdir/obmc-host-start@0.target.requires/phal-reinit-devtree.service"
87 rm $LINK
Chirag Sharma5ec16a32020-12-11 03:45:15 -060088
89 LINK="$D$systemd_system_unitdir/obmc-chassis-poweroff@0.target.requires/proc-pre-poweroff@0.service"
90 rm $LINK
Ramesh Iyyard6d9b542020-09-17 10:02:08 -050091 fi
Andrew Geissler82cfa662020-02-17 15:11:03 -060092}