blob: e2c8ed6606596eb858278d4c1027e08c7be0c8bb [file] [log] [blame]
Patrick Williamsac13d5f2023-11-24 18:59:46 -06001SUMMARY = "A suite of security-related network utilities based on \
2the SSH protocol including the ssh client and sshd server"
3DESCRIPTION = "Secure rlogin/rsh/rcp/telnet replacement (OpenSSH) \
4Ssh (Secure Shell) is a program for logging into a remote machine \
5and for executing commands on a remote machine."
6HOMEPAGE = "http://www.openssh.com/"
7SECTION = "console/network"
8LICENSE = "BSD-2-Clause & BSD-3-Clause & ISC & MIT"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=072979064e691d342002f43cd89c0394"
10
11DEPENDS = "zlib openssl virtual/crypt"
12DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}"
13
14SRC_URI = "http://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/openssh-${PV}.tar.gz \
15 file://sshd_config \
16 file://ssh_config \
17 file://init \
18 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
19 file://sshd.service \
20 file://sshd.socket \
21 file://sshd@.service \
22 file://sshdgenkeys.service \
23 file://volatiles.99_sshd \
24 file://run-ptest \
25 file://fix-potential-signed-overflow-in-pointer-arithmatic.patch \
26 file://sshd_check_keys \
27 file://add-test-support-for-busybox.patch \
28 file://0001-regress-banner.sh-log-input-and-output-files-on-erro.patch \
29 file://0001-systemd-Add-optional-support-for-systemd-sd_notify.patch \
Jose Quaresma634e7972024-07-04 11:56:17 +010030 file://CVE-2024-6387.patch \
Patrick Williamsac13d5f2023-11-24 18:59:46 -060031 "
Patrick Williams44b3caf2024-04-12 16:51:14 -050032SRC_URI[sha256sum] = "490426f766d82a2763fcacd8d83ea3d70798750c7bd2aff2e57dc5660f773ffd"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060033
34CVE_STATUS[CVE-2007-2768] = "not-applicable-config: This CVE is specific to OpenSSH with the pam opie which we don't build/use here."
35
36# This CVE is specific to OpenSSH server, as used in Fedora and Red Hat Enterprise Linux 7
37# and when running in a Kerberos environment. As such it is not relevant to OpenEmbedded
38CVE_STATUS[CVE-2014-9278] = "not-applicable-platform: This CVE is specific to OpenSSH server, as used in Fedora and \
39Red Hat Enterprise Linux 7 and when running in a Kerberos environment"
40
41CVE_STATUS[CVE-2008-3844] = "not-applicable-platform: Only applies to some distributed RHEL binaries."
42
43PAM_SRC_URI = "file://sshd"
44
45inherit manpages useradd update-rc.d update-alternatives systemd
46
47USERADD_PACKAGES = "${PN}-sshd"
48USERADD_PARAM:${PN}-sshd = "--system --no-create-home --home-dir /var/run/sshd --shell /bin/false --user-group sshd"
49INITSCRIPT_PACKAGES = "${PN}-sshd"
50INITSCRIPT_NAME:${PN}-sshd = "sshd"
51INITSCRIPT_PARAMS:${PN}-sshd = "defaults 9"
52
53SYSTEMD_PACKAGES = "${PN}-sshd"
Patrick Williams705982a2024-01-12 09:51:57 -060054SYSTEMD_SERVICE:${PN}-sshd = "${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-socket-mode','sshd.socket', '', d)} ${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-service-mode','sshd.service', '', d)}"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060055
56inherit autotools-brokensep ptest pkgconfig
57DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'systemd', '', d)}"
58
Patrick Williams705982a2024-01-12 09:51:57 -060059# systemd-sshd-socket-mode means installing sshd.socket
60# and systemd-sshd-service-mode corresponding to sshd.service
61PACKAGECONFIG ??= "systemd-sshd-socket-mode"
Patrick Williams2f814a62024-04-16 16:28:03 -050062PACKAGECONFIG[fido2] = "--with-security-key-builtin,--disable-security-key,libfido2"
Patrick Williamsac13d5f2023-11-24 18:59:46 -060063PACKAGECONFIG[kerberos] = "--with-kerberos5,--without-kerberos5,krb5"
64PACKAGECONFIG[ldns] = "--with-ldns,--without-ldns,ldns"
65PACKAGECONFIG[libedit] = "--with-libedit,--without-libedit,libedit"
66PACKAGECONFIG[manpages] = "--with-mantype=man,--with-mantype=cat"
Patrick Williams705982a2024-01-12 09:51:57 -060067PACKAGECONFIG[systemd-sshd-socket-mode] = ""
68PACKAGECONFIG[systemd-sshd-service-mode] = ""
Patrick Williamsac13d5f2023-11-24 18:59:46 -060069
70EXTRA_AUTORECONF += "--exclude=aclocal"
71
72# login path is hardcoded in sshd
73EXTRA_OECONF = "'LOGIN_PROGRAM=${base_bindir}/login' \
74 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)} \
75 --without-zlib-version-check \
76 --with-privsep-path=${localstatedir}/run/sshd \
77 --sysconfdir=${sysconfdir}/ssh \
78 --with-xauth=${bindir}/xauth \
79 --disable-strip \
80 ${@bb.utils.contains('DISTRO_FEATURES', 'systemd', '--with-systemd', '--without-systemd', d)} \
81 "
82
83# musl doesn't implement wtmp/utmp and logwtmp
84EXTRA_OECONF:append:libc-musl = " --disable-wtmp --disable-lastlog"
85
Patrick Williams73bd93f2024-02-20 08:07:48 -060086# Work around ICE on mips/mips64 starting in 9.6p1
87EXTRA_OECONF:append:mips = " --without-hardening"
88EXTRA_OECONF:append:mips64 = " --without-hardening"
89
Patrick Williams03514f12024-04-05 07:04:11 -050090# Work around ICE on powerpc64le starting in 9.6p1
91EXTRA_OECONF:append:powerpc64le = " --without-hardening"
92
Patrick Williamsac13d5f2023-11-24 18:59:46 -060093# Since we do not depend on libbsd, we do not want configure to use it
94# just because it finds libutil.h. But, specifying --disable-libutil
95# causes compile errors, so...
96CACHED_CONFIGUREVARS += "ac_cv_header_bsd_libutil_h=no ac_cv_header_libutil_h=no"
97
98# passwd path is hardcoded in sshd
99CACHED_CONFIGUREVARS += "ac_cv_path_PATH_PASSWD_PROG=${bindir}/passwd"
100
101# We don't want to depend on libblockfile
102CACHED_CONFIGUREVARS += "ac_cv_header_maillock_h=no"
103
104do_configure:prepend () {
105 export LD="${CC}"
106 install -m 0644 ${WORKDIR}/sshd_config ${B}/
107 install -m 0644 ${WORKDIR}/ssh_config ${B}/
108}
109
110do_compile_ptest() {
111 oe_runmake regress-binaries regress-unit-binaries
112}
113
114do_install:append () {
115 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}" ]; then
116 install -D -m 0644 ${WORKDIR}/sshd ${D}${sysconfdir}/pam.d/sshd
117 sed -i -e 's:#UsePAM no:UsePAM yes:' ${D}${sysconfdir}/ssh/sshd_config
118 fi
119
120 if [ "${@bb.utils.filter('DISTRO_FEATURES', 'x11', d)}" ]; then
121 sed -i -e 's:#X11Forwarding no:X11Forwarding yes:' ${D}${sysconfdir}/ssh/sshd_config
122 fi
123
124 install -d ${D}${sysconfdir}/init.d
125 install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/sshd
126 rm -f ${D}${bindir}/slogin ${D}${datadir}/Ssh.bin
127 rmdir ${D}${localstatedir}/run/sshd ${D}${localstatedir}/run ${D}${localstatedir}
128 install -d ${D}/${sysconfdir}/default/volatiles
129 install -m 644 ${WORKDIR}/volatiles.99_sshd ${D}/${sysconfdir}/default/volatiles/99_sshd
130 install -m 0755 ${S}/contrib/ssh-copy-id ${D}${bindir}
131
132 # Create config files for read-only rootfs
133 install -d ${D}${sysconfdir}/ssh
134 install -m 644 ${D}${sysconfdir}/ssh/sshd_config ${D}${sysconfdir}/ssh/sshd_config_readonly
135 sed -i '/HostKey/d' ${D}${sysconfdir}/ssh/sshd_config_readonly
136 echo "HostKey /var/run/ssh/ssh_host_rsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
137 echo "HostKey /var/run/ssh/ssh_host_ecdsa_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
138 echo "HostKey /var/run/ssh/ssh_host_ed25519_key" >> ${D}${sysconfdir}/ssh/sshd_config_readonly
139
140 install -d ${D}${systemd_system_unitdir}
Patrick Williams705982a2024-01-12 09:51:57 -0600141 if ${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-socket-mode','true','false',d)}; then
142 install -c -m 0644 ${WORKDIR}/sshd.socket ${D}${systemd_system_unitdir}
143 install -c -m 0644 ${WORKDIR}/sshd@.service ${D}${systemd_system_unitdir}
144 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
145 -e 's,@SBINDIR@,${sbindir},g' \
146 -e 's,@BINDIR@,${bindir},g' \
147 -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \
148 ${D}${systemd_system_unitdir}/sshd.socket
149 fi
150 if ${@bb.utils.contains('PACKAGECONFIG','systemd-sshd-service-mode','true','false',d)}; then
151 install -c -m 0644 ${WORKDIR}/sshd.service ${D}${systemd_system_unitdir}
152 fi
Patrick Williamsac13d5f2023-11-24 18:59:46 -0600153 install -c -m 0644 ${WORKDIR}/sshdgenkeys.service ${D}${systemd_system_unitdir}
154 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
155 -e 's,@SBINDIR@,${sbindir},g' \
156 -e 's,@BINDIR@,${bindir},g' \
157 -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \
Patrick Williams705982a2024-01-12 09:51:57 -0600158 ${D}${systemd_system_unitdir}/*.service
Patrick Williamsac13d5f2023-11-24 18:59:46 -0600159
160 sed -i -e 's,@LIBEXECDIR@,${libexecdir}/${BPN},g' \
161 ${D}${sysconfdir}/init.d/sshd
162
163 install -D -m 0755 ${WORKDIR}/sshd_check_keys ${D}${libexecdir}/${BPN}/sshd_check_keys
164}
165
166do_install_ptest () {
167 sed -i -e "s|^SFTPSERVER=.*|SFTPSERVER=${libexecdir}/sftp-server|" regress/test-exec.sh
168 cp -r regress ${D}${PTEST_PATH}
169 cp config.h ${D}${PTEST_PATH}
170}
171
172ALLOW_EMPTY:${PN} = "1"
173
174PACKAGES =+ "${PN}-keygen ${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-sftp ${PN}-misc ${PN}-sftp-server"
175FILES:${PN}-scp = "${bindir}/scp.${BPN}"
176FILES:${PN}-ssh = "${bindir}/ssh.${BPN} ${sysconfdir}/ssh/ssh_config"
177FILES:${PN}-sshd = "${sbindir}/sshd ${sysconfdir}/init.d/sshd ${systemd_system_unitdir}"
178FILES:${PN}-sshd += "${sysconfdir}/ssh/moduli ${sysconfdir}/ssh/sshd_config ${sysconfdir}/ssh/sshd_config_readonly ${sysconfdir}/default/volatiles/99_sshd ${sysconfdir}/pam.d/sshd"
179FILES:${PN}-sshd += "${libexecdir}/${BPN}/sshd_check_keys"
180FILES:${PN}-sftp = "${bindir}/sftp"
181FILES:${PN}-sftp-server = "${libexecdir}/sftp-server"
182FILES:${PN}-misc = "${bindir}/ssh* ${libexecdir}/ssh*"
183FILES:${PN}-keygen = "${bindir}/ssh-keygen"
184
185RDEPENDS:${PN} += "${PN}-scp ${PN}-ssh ${PN}-sshd ${PN}-keygen ${PN}-sftp-server"
186RDEPENDS:${PN}-sshd += "${PN}-keygen ${@bb.utils.contains('DISTRO_FEATURES', 'pam', 'pam-plugin-keyinit pam-plugin-loginuid', '', d)}"
187# gdb would make attach-ptrace test pass rather than skip but not worth the build dependencies
188RDEPENDS:${PN}-ptest += "${PN}-sftp ${PN}-misc ${PN}-sftp-server make sed coreutils openssl-bin"
189
190RPROVIDES:${PN}-ssh = "ssh"
191RPROVIDES:${PN}-sshd = "sshd"
192
193RCONFLICTS:${PN} = "dropbear"
194RCONFLICTS:${PN}-sshd = "dropbear"
195
196CONFFILES:${PN}-sshd = "${sysconfdir}/ssh/sshd_config"
197CONFFILES:${PN}-ssh = "${sysconfdir}/ssh/ssh_config"
198
199ALTERNATIVE_PRIORITY = "90"
200ALTERNATIVE:${PN}-scp = "scp"
201ALTERNATIVE:${PN}-ssh = "ssh"
202
203BBCLASSEXTEND += "nativesdk"