Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 1 | SUMMARY = "TinyXML-2 is a simple, small, efficient, C++ XML parser that can be easily integrating into other programs" |
| 2 | HOMEPAGE = "http://www.grinninglizard.com/tinyxml2/" |
| 3 | SECTION = "libs" |
| 4 | LICENSE = "Zlib" |
| 5 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=135624eef03e1f1101b9ba9ac9b5fffd" |
| 6 | |
Andrew Geissler | 6972109 | 2021-07-23 12:57:00 -0400 | [diff] [blame] | 7 | SRCREV = "1dee28e51f9175a31955b9791c74c430fe13dc82" |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 8 | SRC_URI = "git://github.com/leethomason/tinyxml2.git;branch=master;protocol=https \ |
| 9 | file://run-ptest" |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 10 | |
| 11 | S = "${WORKDIR}/git" |
| 12 | |
Patrick Williams | 8e7b46e | 2023-05-01 14:19:06 -0500 | [diff] [blame] | 13 | inherit meson ptest |
| 14 | |
| 15 | EXTRA_OEMESON += "${@bb.utils.contains('PTEST_ENABLED', '1', '-Dtests=true', '', d)}" |
| 16 | |
| 17 | CXXFLAGS:append:libc-musl = " -D_LARGEFILE64_SOURCE" |
| 18 | |
| 19 | do_install_ptest() { |
| 20 | install -Dm 0755 ${B}/xmltest ${D}${PTEST_PATH}/xmltest |
| 21 | install -d ${D}${PTEST_PATH}/resources/out |
| 22 | install -Dm 0644 ${B}/resources/*.xml ${D}${PTEST_PATH}/resources/ |
| 23 | } |
Andrew Geissler | 82c905d | 2020-04-13 13:39:40 -0500 | [diff] [blame] | 24 | |
| 25 | BBCLASSEXTEND = "native" |