Brad Bishop | 08902b0 | 2019-08-20 09:16:51 -0400 | [diff] [blame^] | 1 | SUMMARY = "System load testing utility" |
| 2 | DESCRIPTION = "Deliberately simple workload generator for POSIX systems. It \ |
| 3 | imposes a configurable amount of CPU, memory, I/O, and disk stress on the system." |
| 4 | HOMEPAGE = "https://kernel.ubuntu.com/~cking/stress-ng/" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 7 | |
| 8 | SRC_URI = "https://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \ |
| 9 | file://0001-Do-not-preserve-ownership-when-installing-example-jo.patch \ |
| 10 | file://0001-bash-completion-remove-the-shebang-at-the-start.patch \ |
| 11 | " |
| 12 | SRC_URI[md5sum] = "46aa41d37690324ceab4febfcc549018" |
| 13 | SRC_URI[sha256sum] = "d09dd2a1aea549e478995bf9be90b38906a4cdf33ea7b245ef9d46aa5213c074" |
| 14 | |
| 15 | DEPENDS = "coreutils-native" |
| 16 | |
| 17 | inherit bash-completion |
| 18 | |
| 19 | do_install() { |
| 20 | oe_runmake DESTDIR=${D} install |
| 21 | } |