blob: 5751467db13c67eaae3f70fd9db07c6b8b4bef35 [file] [log] [blame]
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08001require gstreamer1.0-plugins.inc
2
3SRC_URI = " \
4 http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-${PV}.tar.xz \
Brad Bishop15ae2502019-06-18 21:44:24 -04005 file://0001-scaletempo-Advertise-interleaved-layout-in-caps-temp.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08006 file://0001-introspection.m4-prefix-pkgconfig-paths-with-PKG_CON.patch \
Brad Bishop08902b02019-08-20 09:16:51 -04007 file://headerfix.patch \
Brad Bishop1a4b7ee2018-12-16 17:11:34 -08008 "
9
Brad Bishop15ae2502019-06-18 21:44:24 -040010SRC_URI[md5sum] = "d1a7b442994d9522418de4af4330e034"
11SRC_URI[sha256sum] = "654adef33380d604112f702c2927574cfc285e31307b79e584113858838bb0fd"
Brad Bishop1a4b7ee2018-12-16 17:11:34 -080012
13S = "${WORKDIR}/gst-plugins-good-${PV}"
14
15LICENSE = "GPLv2+ & LGPLv2.1+"
16LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
17 file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=a4e1830fce078028c8f0974161272607 \
18 file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
19
20DEPENDS += "gstreamer1.0-plugins-base libcap"
21RPROVIDES_${PN}-pulseaudio += "${PN}-pulse"
22RPROVIDES_${PN}-soup += "${PN}-souphttpsrc"
23
24inherit gettext
25
26PACKAGECONFIG ??= " \
27 ${GSTREAMER_ORC} \
28 ${@bb.utils.filter('DISTRO_FEATURES', 'pulseaudio x11', d)} \
29 bz2 cairo flac gdk-pixbuf gudev jpeg lame libpng mpg123 soup speex taglib v4l2 zlib \
30"
31
32X11DEPENDS = "virtual/libx11 libsm libxrender libxfixes libxdamage"
33
34PACKAGECONFIG[bz2] = "--enable-bz2,--disable-bz2,bzip2"
35PACKAGECONFIG[cairo] = "--enable-cairo,--disable-cairo,cairo"
36PACKAGECONFIG[dv1394] = "--enable-dv1394,--disable-dv1394,libiec61883 libavc1394 libraw1394"
37PACKAGECONFIG[flac] = "--enable-flac,--disable-flac,flac"
38PACKAGECONFIG[gdk-pixbuf] = "--enable-gdk_pixbuf,--disable-gdk_pixbuf,gdk-pixbuf"
39PACKAGECONFIG[gtk] = "--enable-gtk3,--disable-gtk3,gtk+3"
40PACKAGECONFIG[gudev] = "--with-gudev,--without-gudev,libgudev"
41PACKAGECONFIG[jack] = "--enable-jack,--disable-jack,jack"
42PACKAGECONFIG[jpeg] = "--enable-jpeg,--disable-jpeg,jpeg"
43PACKAGECONFIG[lame] = "--enable-lame,--disable-lame,lame"
44PACKAGECONFIG[libpng] = "--enable-libpng,--disable-libpng,libpng"
45PACKAGECONFIG[libv4l2] = "--with-libv4l2,--without-libv4l2,v4l-utils"
46PACKAGECONFIG[mpg123] = "--enable-mpg123,--disable-mpg123,mpg123"
47PACKAGECONFIG[pulseaudio] = "--enable-pulse,--disable-pulse,pulseaudio"
48PACKAGECONFIG[soup] = "--enable-soup,--disable-soup,libsoup-2.4"
49PACKAGECONFIG[speex] = "--enable-speex,--disable-speex,speex"
50PACKAGECONFIG[taglib] = "--enable-taglib,--disable-taglib,taglib"
51PACKAGECONFIG[v4l2] = "--enable-gst_v4l2 --enable-v4l2-probe,--disable-gst_v4l2"
52PACKAGECONFIG[vpx] = "--enable-vpx,--disable-vpx,libvpx"
53PACKAGECONFIG[wavpack] = "--enable-wavpack,--disable-wavpack,wavpack"
54PACKAGECONFIG[x11] = "--enable-x,--disable-x,${X11DEPENDS}"
55PACKAGECONFIG[zlib] = "--enable-zlib,--disable-zlib,zlib"
56
57# qt5 support is disabled, because it is not present in OE core, and requires more work than
58# just adding a packageconfig (it requires access to moc, uic, rcc, and qmake paths).
59# This is better done in a separate qt5 layer (which then should add a "qt5" packageconfig
60# in a gstreamer1.0-plugins-good bbappend).
61
62EXTRA_OECONF += " \
63 --enable-oss \
64 --disable-aalib \
65 --disable-aalibtest \
66 --disable-directsound \
67 --disable-libcaca \
68 --disable-libdv \
69 --disable-oss4 \
70 --disable-osx_audio \
71 --disable-osx_video \
72 --disable-qt \
73 --disable-shout2 \
74 --disable-twolame \
75 --disable-waveform \
76"
77
78FILES_${PN}-equalizer += "${datadir}/gstreamer-1.0/presets/*.prs"