blob: 35f6c6c0a083eef8b7858ad166d63f02bc144dcb [file] [log] [blame]
Andrew Geissler82c905d2020-04-13 13:39:40 -05001SUMMARY = "Invoke py.test as distutils command with dependency resolution"
2LICENSE = "MIT"
Andrew Geissler97771a32021-03-05 15:23:11 -06003LIC_FILES_CHKSUM = "file://LICENSE;md5=7a7126e068206290f3fe9f8d6c713ea6"
Andrew Geissler82c905d2020-04-13 13:39:40 -05004
Andrew Geissler97771a32021-03-05 15:23:11 -06005SRC_URI[sha256sum] = "ca3f58ff4957e8be6c54c55d575b235725cbbcf4dc0d5091c29c6444cfc8a5fe"
Andrew Geissler82c905d2020-04-13 13:39:40 -05006
7inherit pypi setuptools3
8
9DEPENDS += " \
10 ${PYTHON_PN}-setuptools-scm-native"
11
12RDEPENDS_${PN} = "${PYTHON_PN}-py ${PYTHON_PN}-setuptools ${PYTHON_PN}-debugger ${PYTHON_PN}-json \
13 ${PYTHON_PN}-io"
14
15BBCLASSEXTEND = "native nativesdk"