Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 1 | SUMMARY = "Libcomps is alternative for yum.comps library (which is for managing rpm package groups)." |
Andrew Geissler | 90fd73c | 2021-03-05 15:25:55 -0600 | [diff] [blame] | 2 | HOMEPAGE = "https://github.com/rpm-software-management/libcomps" |
| 3 | DESCRIPTION = "Libcomps is alternative for yum.comps library. It's written in pure C as library and there's bindings for python2 and python3." |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 4 | LICENSE = "GPLv2" |
| 5 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" |
| 6 | |
| 7 | SRC_URI = "git://github.com/rpm-software-management/libcomps.git \ |
Brad Bishop | 1932369 | 2019-04-05 15:28:33 -0400 | [diff] [blame] | 8 | file://0001-Add-crc32.c-to-sources-list.patch \ |
Andrew Geissler | c182c62 | 2020-05-15 14:13:32 -0500 | [diff] [blame] | 9 | file://0002-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \ |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 10 | " |
| 11 | |
Andrew Geissler | 0903674 | 2021-06-25 14:25:14 -0500 | [diff] [blame^] | 12 | SRCREV = "dfaffdce1969042bda4a184865861573bb07a5a3" |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 13 | |
| 14 | S = "${WORKDIR}/git" |
| 15 | |
| 16 | inherit cmake distutils3-base |
| 17 | |
| 18 | DEPENDS += "libxml2 expat libcheck" |
| 19 | |
| 20 | EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3" |
| 21 | OECMAKE_SOURCEPATH = "${S}/libcomps" |
| 22 | |
| 23 | BBCLASSEXTEND = "native nativesdk" |
| 24 | |