Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 1 | SUMMARY = "Configuration files for kexecboot" |
| 2 | DESCRIPTION = "Default icon and boot.cfg for kexecboot linux-as-bootloader." |
| 3 | SECTION = "base" |
| 4 | LICENSE = "MIT" |
Brad Bishop | d7bf8c1 | 2018-02-25 22:55:05 -0500 | [diff] [blame] | 5 | LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302" |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 6 | |
| 7 | SRC_URI = "file://icon.xpm" |
| 8 | |
| 9 | S = "${WORKDIR}" |
| 10 | |
| 11 | do_install_prepend () { |
| 12 | echo '# /boot/boot.cfg - KEXECBOOT configuration file. |
| 13 | # |
| 14 | # First kernel stanza. |
| 15 | # Show this label in kexecboot menu. |
| 16 | # |
| 17 | LABEL=${KEXECBOOT_LABEL} |
| 18 | # |
| 19 | # Specify full kernel path on target. |
| 20 | KERNEL=/boot/${KERNEL_IMAGETYPE} |
| 21 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 22 | # Specify which device tree blob to use |
| 23 | # DTB=/boot/my-own-dtb |
| 24 | # |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 25 | # Append this tags to the kernel cmdline. |
| 26 | APPEND=${CMDLINE} ${CMDLINE_DEBUG} |
| 27 | # |
Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 28 | # Overwrite kernel command line instead of appending to it |
| 29 | # CMDLINE=console=/dev/tty0 root=/dev/sdb1 |
| 30 | # |
Patrick Williams | b48b7b4 | 2016-08-17 15:04:38 -0500 | [diff] [blame] | 31 | # Specify optional initrd/initramfs. |
| 32 | # INITRD=/boot/initramfs.cpio.gz |
| 33 | # |
| 34 | # Specify full path for a custom icon for the menu-item. |
| 35 | # If not set, use device-icons as default (NAND, SD, CF, ...). |
| 36 | # ICON=/boot/icon.xpm |
| 37 | # |
| 38 | # Priority of item in kexecboot menu. |
| 39 | # Items with highest priority will be shown at top of menu. |
| 40 | # Default: 0 (lowest, ordered by device ordering) |
| 41 | # PRIORITY=10 |
| 42 | # |
| 43 | # |
| 44 | # Second kernel stanza. |
| 45 | # LABEL=${KEXECBOOT_LABEL}-test |
| 46 | # KERNEL=/boot/${KERNEL_IMAGETYPE}-test |
| 47 | # APPEND=${CMDLINE} |
| 48 | #' > ${S}/boot.cfg |
| 49 | } |
| 50 | do_install () { |
| 51 | install -d ${D}/boot |
| 52 | install -m 0644 boot.cfg ${D}/boot/boot.cfg |
| 53 | install -m 0644 icon.xpm ${D}/boot/icon.xpm |
| 54 | } |
| 55 | |
| 56 | PACKAGE_ARCH = "${MACHINE_ARCH}" |
| 57 | |
| 58 | FILES_${PN} += "/boot/*" |
| 59 | |
| 60 | CMDLINE ?= "" |
| 61 | CMDLINE_DEBUG ?= "quiet" |
| 62 | |
| 63 | INHIBIT_DEFAULT_DEPS = "1" |
| 64 | |
| 65 | # Note: for qvga the label is currently limited to about 24 chars |
Brad Bishop | 6e60e8b | 2018-02-01 10:27:11 -0500 | [diff] [blame] | 66 | KEXECBOOT_LABEL ?= "${@d.getVar('DISTRO') or d.getVar('DISTRO_VERSION')}-${MACHINE}" |