Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "NVMe management command line interface" |
| 2 | AUTHOR = "Stefan Wiehler <stefan.wiehler@missinglinkelectronics.com>" |
| 3 | HOMEPAGE = "https://github.com/linux-nvme/nvme-cli" |
| 4 | SECTION = "console/utils" |
| 5 | LICENSE = "GPLv2" |
| 6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=8264535c0c4e9c6c335635c4026a8022" |
| 7 | DEPENDS = "util-linux" |
| 8 | PV .= "+git${SRCPV}" |
| 9 | |
| 10 | SRC_URI = "git://github.com/linux-nvme/nvme-cli.git \ |
| 11 | file://0001-Makefile-fix-bash-completion-install-path.patch \ |
| 12 | " |
| 13 | SRCREV = "642d426faf8a67ed01e90f7c35c0d967f8cc52a3" |
| 14 | |
| 15 | S = "${WORKDIR}/git" |
| 16 | |
| 17 | inherit bash-completion |
| 18 | |
| 19 | do_install() { |
| 20 | oe_runmake PREFIX=${prefix} DESTDIR=${D} install |
| 21 | } |