Brad Bishop | 1a4b7ee | 2018-12-16 17:11:34 -0800 | [diff] [blame] | 1 | SUMMARY = "Checksumming Copy on Write Filesystem utilities" |
| 2 | DESCRIPTION = "Btrfs is a new copy on write filesystem for Linux aimed at \ |
| 3 | implementing advanced features while focusing on fault tolerance, repair and \ |
| 4 | easy administration. \ |
| 5 | This package contains utilities (mkfs, fsck, btrfsctl) used to work with \ |
| 6 | btrfs and an utility (btrfs-convert) to make a btrfs filesystem from an ext3." |
| 7 | |
| 8 | HOMEPAGE = "https://btrfs.wiki.kernel.org" |
| 9 | |
| 10 | LICENSE = "GPLv2" |
| 11 | LIC_FILES_CHKSUM = "file://COPYING;md5=fcb02dc552a041dee27e4b85c7396067" |
| 12 | SECTION = "base" |
| 13 | DEPENDS = "util-linux attr e2fsprogs lzo acl python3-setuptools-native" |
| 14 | DEPENDS_append_class-target = " udev" |
| 15 | RDEPENDS_${PN} = "libgcc" |
| 16 | |
| 17 | SRCREV = "7faaca0d9f78f7162ae603231f693dd8e1af2a41" |
| 18 | SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/kdave/btrfs-progs.git \ |
| 19 | file://0001-Makefile-build-mktables-using-native-gcc.patch \ |
| 20 | file://0001-Add-LDFLAGS-when-building-libbtrfsutil.so.patch \ |
| 21 | file://0001-Add-a-possibility-to-specify-where-python-modules-ar.patch \ |
| 22 | " |
| 23 | |
| 24 | inherit autotools-brokensep pkgconfig manpages distutils3-base |
| 25 | |
| 26 | CLEANBROKEN = "1" |
| 27 | |
| 28 | PACKAGECONFIG[manpages] = "--enable-documentation, --disable-documentation, asciidoc-native xmlto-native" |
| 29 | EXTRA_OECONF = " --disable-zstd" |
| 30 | EXTRA_OECONF_append_libc-musl = " --disable-backtrace " |
| 31 | |
| 32 | do_configure_prepend() { |
| 33 | # Upstream doesn't ship this and autoreconf won't install it as automake isn't used. |
| 34 | mkdir -p ${S}/config |
| 35 | cp -f $(automake --print-libdir)/install-sh ${S}/config/ |
| 36 | } |
| 37 | |
| 38 | S = "${WORKDIR}/git" |
| 39 | |
| 40 | do_install_append() { |
| 41 | oe_runmake 'DESTDIR=${D}' 'PYTHON_SITEPACKAGES_DIR=${PYTHON_SITEPACKAGES_DIR}' install_python |
| 42 | } |
| 43 | |
| 44 | BBCLASSEXTEND = "native" |